summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-18 15:04:03 -0400
committerJean Lucas2019-04-18 15:52:27 -0400
commit672edd17acea79e53aa91cc956e7e20166ad1b90 (patch)
tree46a0fbcc71f358252647b3f7f6e0adc383ecbe9a
downloadaur-672edd17acea79e53aa91cc956e7e20166ad1b90.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2433158e6a2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Apr 18 19:52:17 UTC 2019
+pkgbase = zerotwo
+ pkgdesc = AniList Anime tracker written with Electron & Vue.js
+ pkgver = 0.6.2+beta
+ pkgrel = 1
+ url = https://www.zerotwo.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = npm
+ conflicts = zerotwo-bin
+ conflicts = zerotwo-git
+ source = https://github.com/NicoAiko/zerotwo/archive/v0.6.2-beta.tar.gz
+ sha512sums = 077efb8bbdf2dd86366fc61aa985521c04f316c3ba0e6ac7439332c35f423a37008d0a0ee3b75b89669533861c36cebf81d5bc018526d8dd5257e01477e07396
+
+pkgname = zerotwo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a22fbb8ae181
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=zerotwo
+pkgver=0.6.2+beta
+pkgrel=1
+pkgdesc='AniList Anime tracker written with Electron & Vue.js'
+arch=(i686 x86_64)
+url=https://www.zerotwo.org
+license=(GPL3)
+conflicts=(zerotwo-bin zerotwo-git)
+makedepends=(npm)
+source=(https://github.com/NicoAiko/zerotwo/archive/v${pkgver/+/-}.tar.gz)
+sha512sums=('077efb8bbdf2dd86366fc61aa985521c04f316c3ba0e6ac7439332c35f423a37008d0a0ee3b75b89669533861c36cebf81d5bc018526d8dd5257e01477e07396')
+
+build() {
+ cd zerotwo-${pkgver/+/-}
+ npm i
+ NODE_ENV=production \
+ ELECTRON_BUILDER_ALLOW_UNRESOLVED_DEPENDENCIES=true \
+ npm run build:dir
+}
+
+package() {
+ install -d "$pkgdir"/usr/{share,bin}
+ cp -a zerotwo-${pkgver/+/-}/build/linux-unpacked \
+ "$pkgdir"/usr/share/zerotwo
+ ln -s /usr/share/zerotwo/zerotwo-ui "$pkgdir"/usr/bin/zerotwo
+}