summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-18 18:44:10 -0400
committerJean Lucas2019-04-18 18:51:28 -0400
commitdd063799e474cfc8503a7b6245df60489ccc2cd9 (patch)
treee54dd684f0880a67ebbca8b3c89acd827a7f2a5f
parent672edd17acea79e53aa91cc956e7e20166ad1b90 (diff)
downloadaur-dd063799e474cfc8503a7b6245df60489ccc2cd9.tar.gz
Add API keys requirement, add desktop file and icons
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
-rw-r--r--zerotwo.desktop9
3 files changed, 35 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2433158e6a2c..970e83eed52d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 18 19:52:17 UTC 2019
+# Thu Apr 18 22:50:36 UTC 2019
pkgbase = zerotwo
- pkgdesc = AniList Anime tracker written with Electron & Vue.js
+ pkgdesc = AniList anime tracker written with Electron & Vue.js
pkgver = 0.6.2+beta
- pkgrel = 1
+ pkgrel = 2
url = https://www.zerotwo.org
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = zerotwo
conflicts = zerotwo-bin
conflicts = zerotwo-git
source = https://github.com/NicoAiko/zerotwo/archive/v0.6.2-beta.tar.gz
+ source = zerotwo.desktop
sha512sums = 077efb8bbdf2dd86366fc61aa985521c04f316c3ba0e6ac7439332c35f423a37008d0a0ee3b75b89669533861c36cebf81d5bc018526d8dd5257e01477e07396
+ sha512sums = 8811f73498b76d5985e819d40d84b1a88919c71b563de8ca58a831e9ffd5b1ec54d525d263a01c053a761385712669deb993824545af98e51d2ce73f96788bd3
pkgname = zerotwo
diff --git a/PKGBUILD b/PKGBUILD
index a22fbb8ae181..a0b277ecab52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,26 @@
pkgname=zerotwo
pkgver=0.6.2+beta
-pkgrel=1
-pkgdesc='AniList Anime tracker written with Electron & Vue.js'
+pkgrel=2
+pkgdesc='AniList anime tracker written with Electron & Vue.js'
arch=(i686 x86_64)
url=https://www.zerotwo.org
license=(GPL3)
conflicts=(zerotwo-bin zerotwo-git)
makedepends=(npm)
-source=(https://github.com/NicoAiko/zerotwo/archive/v${pkgver/+/-}.tar.gz)
-sha512sums=('077efb8bbdf2dd86366fc61aa985521c04f316c3ba0e6ac7439332c35f423a37008d0a0ee3b75b89669533861c36cebf81d5bc018526d8dd5257e01477e07396')
+source=(https://github.com/NicoAiko/zerotwo/archive/v${pkgver/+/-}.tar.gz
+ zerotwo.desktop)
+sha512sums=('077efb8bbdf2dd86366fc61aa985521c04f316c3ba0e6ac7439332c35f423a37008d0a0ee3b75b89669533861c36cebf81d5bc018526d8dd5257e01477e07396'
+ '8811f73498b76d5985e819d40d84b1a88919c71b563de8ca58a831e9ffd5b1ec54d525d263a01c053a761385712669deb993824545af98e51d2ce73f96788bd3')
build() {
cd zerotwo-${pkgver/+/-}
+
+ # You must generate an API client ID and secret on AniList in order to use the login function
+ _api_id=
+ _api_secret=
+ echo -e CLIENT_ID=${_api_id}'\n'CLIENT_SECRET=${_api_secret} > .env
+
npm i
NODE_ENV=production \
ELECTRON_BUILDER_ALLOW_UNRESOLVED_DEPENDENCIES=true \
@@ -22,7 +30,14 @@ build() {
package() {
install -d "$pkgdir"/usr/{share,bin}
- cp -a zerotwo-${pkgver/+/-}/build/linux-unpacked \
- "$pkgdir"/usr/share/zerotwo
+ install -Dm 644 zerotwo.desktop -t "$pkgdir"/usr/share/applications
+
+ cd zerotwo-${pkgver/+/-}/build
+
+ cp -a linux-unpacked "$pkgdir"/usr/share/zerotwo
ln -s /usr/share/zerotwo/zerotwo-ui "$pkgdir"/usr/bin/zerotwo
+
+ for i in 16 32 64 128 256 512 1024 ; do
+ install -Dm 644 icons/ZeroTwoAppIcon_$i* "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zerotwo.png
+ done
}
diff --git a/zerotwo.desktop b/zerotwo.desktop
new file mode 100644
index 000000000000..b6fd1db47179
--- /dev/null
+++ b/zerotwo.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=ZeroTwo
+Comment=AniList anime tracker
+Exec=zerotwo
+Terminal=false
+Type=Application
+Icon=zerotwo
+StartupWMClass=ZeroTwo
+Categories=Network;