summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-23 20:33:50 -0400
committerJean Lucas2019-06-23 20:33:50 -0400
commit2364de08a5fc9cacece363d2d4bf1792bac5b534 (patch)
treedfed80a1e5015b7e150d51037174f5125d365c62
parentcb4c51cdb9ee9e4cc15b2b398ba056431d94d03b (diff)
downloadaur-2364de08a5fc9cacece363d2d4bf1792bac5b534.tar.gz
Add provides
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21c26dac97f0..a2aa60cb06a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Apr 19 00:31:54 UTC 2019
pkgbase = zerotwo-git
pkgdesc = AniList anime tracker written with Electron & Vue.js (git)
pkgver = 0.6.2+beta
- pkgrel = 3
+ pkgrel = 4
url = https://www.zerotwo.org
arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = npm
+ provides = zerotwo
conflicts = zerotwo
conflicts = zerotwo-bin
source = git+https://github.com/NicoAiko/zerotwo
diff --git a/PKGBUILD b/PKGBUILD
index fbe14684c3f8..7f210c5e4371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=zerotwo-git
pkgver=0.6.2+beta
-pkgrel=3
+pkgrel=4
pkgdesc='AniList anime tracker written with Electron & Vue.js (git)'
arch=(i686 x86_64)
url=https://www.zerotwo.org
license=(GPL3)
+provides=(zerotwo)
conflicts=(zerotwo zerotwo-bin)
makedepends=(git npm)
source=(git+https://github.com/NicoAiko/zerotwo
@@ -26,7 +27,7 @@ build() {
# Generate them at https://anilist.co/settings/developer
_api_id=
_api_secret=
- if [ -z $_api_id ] || [ -z $_api_secret ] ; then
+ if [ -z $_api_id ] || [ -z $_api_secret ]; then
echo "AniList API client ID and secret must be manually set for ZeroTwo to function properly. Quitting..."
exit
fi
@@ -47,7 +48,7 @@ package() {
cp -a linux-unpacked "$pkgdir"/usr/share/zerotwo
ln -s /usr/share/zerotwo/zerotwo-ui "$pkgdir"/usr/bin/zerotwo
- for i in 16 32 64 128 256 512 1024 ; do
+ for i in 16 32 64 128 256 512 1024; do
install -Dm 644 icons/ZeroTwoAppIcon_$i* "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zerotwo.png
done
}