summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-18 19:02:23 -0400
committerJean Lucas2019-04-18 19:02:23 -0400
commit3ac891b2d2738de7c4368aa9ef8406d9f4952c3f (patch)
tree875d5fa84d127ec8b509c02cbbf8938f2d423019
parent40e18a1319577dddbe672f4666ef14dfc11d2d86 (diff)
downloadaur-3ac891b2d2738de7c4368aa9ef8406d9f4952c3f.tar.gz
Add API keys requirement, add desktop file and icons
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
-rw-r--r--zerotwo.desktop9
3 files changed, 36 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55c06dd8c897..f02c05b52273 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 18 19:54:17 UTC 2019
+# Thu Apr 18 23:01:43 UTC 2019
pkgbase = zerotwo-git
- pkgdesc = AniList Anime tracker written with Electron & Vue.js (git)
- pkgver = v0.6.2+beta
- pkgrel = 1
+ pkgdesc = AniList anime tracker written with Electron & Vue.js (git)
+ pkgver = 0.6.2+beta
+ pkgrel = 2
url = https://www.zerotwo.org
arch = i686
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = zerotwo-git
conflicts = zerotwo
conflicts = zerotwo-bin
source = git+https://github.com/NicoAiko/zerotwo
+ source = zerotwo.desktop
sha512sums = SKIP
+ sha512sums = 8811f73498b76d5985e819d40d84b1a88919c71b563de8ca58a831e9ffd5b1ec54d525d263a01c053a761385712669deb993824545af98e51d2ce73f96788bd3
pkgname = zerotwo-git
diff --git a/PKGBUILD b/PKGBUILD
index 9fa74d14dc50..aad3d6296bd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname=zerotwo-git
pkgver=0.6.2+beta
-pkgrel=1
-pkgdesc='AniList Anime tracker written with Electron & Vue.js (git)'
+pkgrel=2
+pkgdesc='AniList anime tracker written with Electron & Vue.js (git)'
arch=(i686 x86_64)
url=https://www.zerotwo.org
license=(GPL3)
conflicts=(zerotwo zerotwo-bin)
makedepends=(git npm)
-source=(git+https://github.com/NicoAiko/zerotwo)
-sha512sums=('SKIP')
+source=(git+https://github.com/NicoAiko/zerotwo
+ zerotwo.desktop)
+sha512sums=('SKIP'
+ '8811f73498b76d5985e819d40d84b1a88919c71b563de8ca58a831e9ffd5b1ec54d525d263a01c053a761385712669deb993824545af98e51d2ce73f96788bd3')
pkgver() {
cd zerotwo
@@ -19,6 +21,12 @@ pkgver() {
build() {
cd zerotwo
+
+ # You must generate an API client ID and secret on AniList in order to use the login function
+ _api_id=
+ _api_secret=
+ echo -e CLIENT_ID=${_api_id}'\n'CLIENT_SECRET=${_api_secret} > .env
+
npm i
NODE_ENV=production \
ELECTRON_BUILDER_ALLOW_UNRESOLVED_DEPENDENCIES=true \
@@ -27,7 +35,14 @@ build() {
package() {
install -d "$pkgdir"/usr/{share,bin}
- cp -a zerotwo/build/linux-unpacked \
- "$pkgdir"/usr/share/zerotwo
+ install -Dm 644 zerotwo.desktop -t "$pkgdir"/usr/share/applications
+
+ cd zerotwo/build
+
+ cp -a linux-unpacked "$pkgdir"/usr/share/zerotwo
ln -s /usr/share/zerotwo/zerotwo-ui "$pkgdir"/usr/bin/zerotwo
+
+ for i in 16 32 64 128 256 512 1024 ; do
+ install -Dm 644 icons/ZeroTwoAppIcon_$i* "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zerotwo.png
+ done
}
diff --git a/zerotwo.desktop b/zerotwo.desktop
new file mode 100644
index 000000000000..b6fd1db47179
--- /dev/null
+++ b/zerotwo.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=ZeroTwo
+Comment=AniList anime tracker
+Exec=zerotwo
+Terminal=false
+Type=Application
+Icon=zerotwo
+StartupWMClass=ZeroTwo
+Categories=Network;