summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-14 22:40:41 -0400
committerJean Lucas2019-08-14 22:44:25 -0400
commit70c6d96eed3a60965c52b337fa18c7a5d2fbf7a3 (patch)
tree1aba5c12542e27c91a9a8ec106d2e5a29c32ee37
parent2364de08a5fc9cacece363d2d4bf1792bac5b534 (diff)
downloadaur-70c6d96eed3a60965c52b337fa18c7a5d2fbf7a3.tar.gz
Update deps, pkgver schema, upstream source; install license; improve readability; move program directory to /lib
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD28
-rw-r--r--zerotwo.desktop6
3 files changed, 49 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2aa60cb06a6..5e78ce0bf424 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,45 @@
pkgbase = zerotwo-git
pkgdesc = AniList anime tracker written with Electron & Vue.js (git)
- pkgver = 0.6.2+beta
- pkgrel = 4
+ pkgver = 0.6.2beta+r1+g3f49920
+ pkgrel = 1
url = https://www.zerotwo.org
arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = npm
+ depends = alsa-lib
+ depends = atk
+ depends = at-spi2-atk
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libcups
+ depends = libglvnd
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = pango
provides = zerotwo
conflicts = zerotwo
conflicts = zerotwo-bin
- source = git+https://github.com/NicoAiko/zerotwo
+ source = git+https://gitlab.com/NicoAiko/zerotwo
source = zerotwo.desktop
sha512sums = SKIP
- sha512sums = 8811f73498b76d5985e819d40d84b1a88919c71b563de8ca58a831e9ffd5b1ec54d525d263a01c053a761385712669deb993824545af98e51d2ce73f96788bd3
+ sha512sums = d322d1fc1e78086a0dad38d3272fe1bebde3db750f0cd38c5995e7b2c819ab60d3a941792056d5fe2b431c968adae47b01b22d0d1bd8646b74967ad8000d789a
pkgname = zerotwo-git
diff --git a/PKGBUILD b/PKGBUILD
index 7f210c5e4371..be59934e835c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=zerotwo-git
-pkgver=0.6.2+beta
-pkgrel=4
+pkgver=0.6.2beta+r1+g3f49920
+pkgrel=1
pkgdesc='AniList anime tracker written with Electron & Vue.js (git)'
arch=(i686 x86_64)
url=https://www.zerotwo.org
license=(GPL3)
provides=(zerotwo)
conflicts=(zerotwo zerotwo-bin)
+depends=(alsa-lib atk at-spi2-atk cairo gdk-pixbuf2 glib2 gtk3 hicolor-icon-theme libcups libglvnd libx11 libxcb libxcomposite libxcursor libxdamage libxext libxfixes libxi libxrandr libxrender libxss libxtst nspr nss pango)
makedepends=(git npm)
-source=(git+https://github.com/NicoAiko/zerotwo
+source=(git+https://gitlab.com/NicoAiko/zerotwo
zerotwo.desktop)
sha512sums=('SKIP'
- '8811f73498b76d5985e819d40d84b1a88919c71b563de8ca58a831e9ffd5b1ec54d525d263a01c053a761385712669deb993824545af98e51d2ce73f96788bd3')
+ 'd322d1fc1e78086a0dad38d3272fe1bebde3db750f0cd38c5995e7b2c819ab60d3a941792056d5fe2b431c968adae47b01b22d0d1bd8646b74967ad8000d789a')
pkgver() {
cd zerotwo
- git describe --tags | sed 's#v##;s#-#+#'
+ if [ $(git describe --tags | grep beta) ]; then
+ git describe --tags | sed 's#v##;s#-#+#g;s#+\([a-zA-Z]\)#\1#;s#+\([0-9]\)#+r\1#'
+ else git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
+ fi
}
build() {
@@ -40,15 +44,17 @@ build() {
}
package() {
- install -d "$pkgdir"/usr/{share,bin}
- install -Dm 644 zerotwo.desktop -t "$pkgdir"/usr/share/applications
-
cd zerotwo/build
- cp -a linux-unpacked "$pkgdir"/usr/share/zerotwo
- ln -s /usr/share/zerotwo/zerotwo-ui "$pkgdir"/usr/bin/zerotwo
+ install -d "$pkgdir"/usr/{lib,bin}
+ cp -a linux-unpacked "$pkgdir"/usr/lib/zerotwo
+ ln -s /usr/lib/zerotwo/zerotwo-ui "$pkgdir"/usr/bin/zerotwo
+ install -Dm 644 ../../zerotwo.desktop -t "$pkgdir"/usr/share/applications
for i in 16 32 64 128 256 512 1024; do
- install -Dm 644 icons/ZeroTwoAppIcon_$i* "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zerotwo.png
+ install -Dm 644 icons/ZeroTwoAppIcon_$i.png \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zerotwo.png
done
+
+ install -Dm 644 ../LICENSE -t "$pkgdir"/usr/share/licenses/zerotwo
}
diff --git a/zerotwo.desktop b/zerotwo.desktop
index b6fd1db47179..64cfd9a16c7b 100644
--- a/zerotwo.desktop
+++ b/zerotwo.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
+Version=1.0
+Type=Application
Name=ZeroTwo
Comment=AniList anime tracker
Exec=zerotwo
-Terminal=false
-Type=Application
Icon=zerotwo
-StartupWMClass=ZeroTwo
Categories=Network;
+Terminal=false