summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-18 21:05:44 -0400
committerJean Lucas2019-04-18 21:05:44 -0400
commitcb4c51cdb9ee9e4cc15b2b398ba056431d94d03b (patch)
treed02a13e5ea7f17ef813fa19b53d3459898bc2a39
parent3ac891b2d2738de7c4368aa9ef8406d9f4952c3f (diff)
downloadaur-cb4c51cdb9ee9e4cc15b2b398ba056431d94d03b.tar.gz
Quit if API details are not set
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f02c05b52273..21c26dac97f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 18 23:01:43 UTC 2019
+# Fri Apr 19 00:31:54 UTC 2019
pkgbase = zerotwo-git
pkgdesc = AniList anime tracker written with Electron & Vue.js (git)
pkgver = 0.6.2+beta
- pkgrel = 2
+ pkgrel = 3
url = https://www.zerotwo.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index aad3d6296bd6..fbe14684c3f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zerotwo-git
pkgver=0.6.2+beta
-pkgrel=2
+pkgrel=3
pkgdesc='AniList anime tracker written with Electron & Vue.js (git)'
arch=(i686 x86_64)
url=https://www.zerotwo.org
@@ -23,8 +23,13 @@ build() {
cd zerotwo
# You must generate an API client ID and secret on AniList in order to use the login function
+ # Generate them at https://anilist.co/settings/developer
_api_id=
_api_secret=
+ if [ -z $_api_id ] || [ -z $_api_secret ] ; then
+ echo "AniList API client ID and secret must be manually set for ZeroTwo to function properly. Quitting..."
+ exit
+ fi
echo -e CLIENT_ID=${_api_id}'\n'CLIENT_SECRET=${_api_secret} > .env
npm i