summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfonso Saavedra Son2015-07-06 10:35:15 +0200
committerAlfonso Saavedra Son2015-07-06 10:35:15 +0200
commit3961c3fe6e578e4a23554f14cfd1598587aae292 (patch)
tree20c1f4209ade544aabc03bba5f8386506b853701
downloadaur-3961c3fe6e578e4a23554f14cfd1598587aae292.tar.gz
Import and updated to 3.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1dac8fe605cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = zesarux
+ pkgdesc = A Zx80/Zx81/Z88, Zx Spectrum 16/48/128/+2/+2A and ZX-Uno emulator with ULAPlus support
+ pkgver = 3.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/zesarux/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ optdepends = pulseaudio: for support Pulseaudio
+ optdepends = openssl: for enable SSL functions
+ conflicts = zesarux-git
+ source = http://sourceforge.net/projects/zesarux/files/ZEsarUX-3.0/ZEsarUX_src-3.0.tar.gz
+ md5sums = 6a670e31af81d4482e0675d4fdfd2e2d
+
+pkgname = zesarux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98be2055894c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
+
+pkgname=zesarux
+pkgver=3.0
+pkgrel=1
+pkgdesc="A Zx80/Zx81/Z88, Zx Spectrum 16/48/128/+2/+2A and ZX-Uno emulator with ULAPlus support"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/zesarux/"
+license=('GPL3')
+conflicts=('zesarux-git')
+depens=('lesstif')
+optdepends=('pulseaudio: for support Pulseaudio'
+ 'openssl: for enable SSL functions')
+
+source=("http://sourceforge.net/projects/zesarux/files/ZEsarUX-${pkgver}/ZEsarUX_src-${pkgver}.tar.gz")
+md5sums=('6a670e31af81d4482e0675d4fdfd2e2d')
+
+build() {
+ cd "${srcdir}/ZEsarUX-${pkgver}"
+ ./configure --prefix /usr --disable-caca --disable-aa --disable-xext
+ make
+}
+package(){
+ if [ ! -d "${pkgdir}/usr" ]; then
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/zesarux/"
+ fi
+ cd ${srcdir}/ZEsarUX-${pkgver}
+ cp zesarux "${pkgdir}/usr/bin/"
+ cp *.rom "${pkgdir}/usr/share/zesarux/"
+ cp -r tapes "${pkgdir}/usr/share/zesarux/"
+ cp ACKNOWLEDGEMENTS Changelog HISTORY LICENSE README FEATURES INSTALL ALTERNATEROMS INCLUDEDTAPES "${pkgdir}/usr/share/zesarux/"
+ find "${pkgdir}/usr/share/zesarux/" -type f -print0| xargs -0 chmod 444
+}