summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrLi2021-10-17 04:59:41 +0800
committerBrLi2021-10-17 04:59:41 +0800
commitcfaf56e0e9e730e001ff91bcd3f533dbae524dee (patch)
tree0736e24ac56a6f56ef28e0db8981a0f343235b63
parent6c1adfaa6c02e51f759436ff6aa44a3cdb05937a (diff)
downloadaur-cfaf56e0e9e730e001ff91bcd3f533dbae524dee.tar.gz
patch to avoid download pandoc, is done via makepkg
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Do-not-download-pandoc.patch29
-rw-r--r--PKGBUILD4
3 files changed, 37 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed3f8a9ea42e..b417d913e4c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zettlr
pkgdesc = A markdown editor for writing academic texts and taking notes
pkgver = 2.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.zettlr.com
install = install
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = zettlr
optdepends = ttf-lato: Display output in a more comfortable way
options = !strip
source = zettlr-2.0.0.tar.gz::https://github.com/Zettlr/Zettlr/archive/v2.0.0.tar.gz
- source = locales-2.0.0-3.zip::https://github.com/citation-style-language/locales/archive/0cc3885f6100e26ac6c6d103efa6f3d7195fd21b.zip
- source = chicago-author-date-2.0.0-3.csl::https://github.com/citation-style-language/styles/raw/3a6a0a7bc1410075c606e51cab45877cc76f1f69/chicago-author-date.csl
+ source = 0001-Do-not-download-pandoc.patch
+ source = locales-2.0.0-4.zip::https://github.com/citation-style-language/locales/archive/0cc3885f6100e26ac6c6d103efa6f3d7195fd21b.zip
+ source = chicago-author-date-2.0.0-4.csl::https://github.com/citation-style-language/styles/raw/3a6a0a7bc1410075c606e51cab45877cc76f1f69/chicago-author-date.csl
sha256sums = b23d3a7e802ff4be31dd4dfb43fb54272a3935aec665e09b79c4b369da80ae8f
+ sha256sums = 97d1e620226324a1b7e5571ca800286a62f17e3729b08383918be81b64530287
sha256sums = 9b3e987aefb10da8b2baadd06e751e978ea23dc7b6297802cbda0ec6806744e2
sha256sums = 1455e57b314fd13ba155f4ab93f061e3e6393c13cd0f16380adb9d73614f7930
diff --git a/0001-Do-not-download-pandoc.patch b/0001-Do-not-download-pandoc.patch
new file mode 100644
index 000000000000..960d70131914
--- /dev/null
+++ b/0001-Do-not-download-pandoc.patch
@@ -0,0 +1,29 @@
+From f4eba18c684a952f916816b7a005744a4fb1418f Mon Sep 17 00:00:00 2001
+From: BrLi <brli@chakralinux.org>
+Date: Mon, 26 Apr 2021 14:38:31 +0800
+Subject: [PATCH 2/2] Do-not-download-pandoc
+
+---
+ forge.config.js | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/forge.config.js b/forge.config.js
+index 4cfe7b2a..8010d8e6 100644
+--- a/forge.config.js
++++ b/forge.config.js
+@@ -102,10 +102,10 @@ module.exports = {
+ try {
+ await fs.lstat(path.join(__dirname, `./resources/pandoc-${platform}-${arch}`))
+ } catch (err) {
+- await downloadPandoc(platform, arch)
++ console.log('\nSkip pandoc executable download on Arch')
+ }
+
+- await fs.copyFile(path.join(__dirname, `./resources/pandoc-${platform}-${arch}`), path.join(__dirname, './resources/pandoc'))
++ console.log('\nDo not copy pandoc executable, is taking cared of via PKGBUILD')
+
+ forgeConfig.packagerConfig.extraResource.push('./resources/pandoc')
+ } else {
+--
+2.31.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 6d387d367bf3..39ce4b9bff6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _bundle_pandoc=false
pkgname=zettlr
pkgver=2.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url='https://www.zettlr.com'
@@ -23,10 +23,12 @@ _pandoc_binary_ver=2.14.2 # check scripts/get-pandoc.sh for update
options=(!strip)
install=install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Zettlr/Zettlr/archive/v${pkgver}.tar.gz"
+ '0001-Do-not-download-pandoc.patch'
# citation style
"locales-${pkgver}-${pkgrel}.zip::https://github.com/citation-style-language/locales/archive/${_csl_locale_commit}.zip"
"chicago-author-date-${pkgver}-${pkgrel}.csl::https://github.com/citation-style-language/styles/raw/${_csl_style_commit}/chicago-author-date.csl")
sha256sums=('b23d3a7e802ff4be31dd4dfb43fb54272a3935aec665e09b79c4b369da80ae8f'
+ '97d1e620226324a1b7e5571ca800286a62f17e3729b08383918be81b64530287'
'9b3e987aefb10da8b2baadd06e751e978ea23dc7b6297802cbda0ec6806744e2'
'1455e57b314fd13ba155f4ab93f061e3e6393c13cd0f16380adb9d73614f7930')
if ${_bundle_pandoc} ; then