summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrLi2019-06-17 12:46:26 +0800
committerBrLi2019-06-17 12:46:26 +0800
commit472f949cf1da033d4d2d54a865e3396e12976d3c (patch)
tree73272807730d9ce7e5dcf1e96c7b6253f192e158
parent43a77eabad67619649b3f0c3321344b6d421ef04 (diff)
downloadaur-472f949cf1da033d4d2d54a865e3396e12976d3c.tar.gz
updpkg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4652d107b70..a2702d5702a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = zettlr
pkgdesc = A markdown editor for writing academic texts and taking notes
- pkgver = 1.3.0.b2
+ pkgver = 1.3.0
pkgrel = 1
url = https://www.zettlr.com
arch = x86_64
license = GPL
makedepends = yarn
+ makedepends = git
depends = electron
+ depends = ttf-webhostinghub-glyphs
+ depends = otf-crimson-text
optdepends = pandoc: For exporting to various format
optdepends = texlive-bin: For Latex support
- source = zettlr::git+https://github.com/Zettlr/Zettlr.git#tag=v1.3.0-beta.2
+ optdepends = ttf-lato: Display output in a more comfortable way
+ source = zettlr::git+https://github.com/Zettlr/Zettlr.git#tag=v1.3.0
sha1sums = SKIP
pkgname = zettlr
diff --git a/PKGBUILD b/PKGBUILD
index 0143bb4c76c3..f497f69af9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: weearc <qby19981121@gmail.com>
-# Co-Maintainer: therojam <archlinux@therojam.xyz>
+# Maintainer: BrLi <brli@chakralinux.org>
pkgname=zettlr
-pkgver=1.3.0.b2
+pkgver=1.3.0
pkgrel=1
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url="https://www.zettlr.com"
license=('GPL')
-depends=(electron)
-makedepends=(yarn)
+depends=(electron ttf-webhostinghub-glyphs otf-crimson-text)
+makedepends=(yarn git)
optdepends=('pandoc: For exporting to various format'
- 'texlive-bin: For Latex support')
-source=($pkgname::git+https://github.com/Zettlr/Zettlr.git#tag=v1.3.0-beta.2)
+ 'texlive-bin: For Latex support'
+ 'ttf-lato: Display output in a more comfortable way')
+source=($pkgname::git+https://github.com/Zettlr/Zettlr.git#tag=v$pkgver)
sha1sums=(SKIP)
build() {
@@ -24,14 +24,18 @@ build() {
cd $srcdir/$pkgname/source
yarn install --pure-lockfile
-
}
+
package() {
install -dm 755 "$pkgdir"/usr/lib/$pkgname
cd $srcdir/$pkgname/
cp -r --no-preserve=ownership --preserve=mode source/* "$pkgdir"/usr/lib/$pkgname/
+ # Remove unneeded addin
+ find $pkgdir/usr/lib/zettlr -name "fonts" -exec rm -rfv "{}"\;
+ find $pkgdir/usr/lib/zettlr -name ".gitignore" -or -name ".eslintrc.json" -or -name ".npmignore" -exec rm -rfv "{}"\;
+
install -Dm755 /dev/stdin $pkgdir/usr/bin/$pkgname <<END
#!/bin/bash
exec electron /usr/lib/$pkgname "$@"