summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthreadexio2022-04-17 04:02:21 +0300
committerthreadexio2022-04-17 04:02:21 +0300
commit9286d27e8cd6c7f72b1215f13331616a25e1c18c (patch)
tree247477f07f3c03c370b8a130dabee9d1d4431430
downloadaur-9286d27e8cd6c7f72b1215f13331616a25e1c18c.tar.gz
First version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0d16639be00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = zeus-bin
+ pkgdesc = The containerized AUR helper
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/threadexio/zeus
+ arch = x86_64
+ license = MIT
+ depends = docker
+ conflicts = zeus
+ source = https://github.com/threadexio/zeus/releases/download/v1.0.0/zeus-bin.zip
+ sha256sums = bf74db8dc15c5f4257bb33f8bc237e564d1a7282bd96cca5865474e78738b798
+
+pkgname = zeus-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ee300dbea7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: threadexio <pzarganitis at gmail dot com>
+pkgname=zeus-bin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="The containerized AUR helper"
+url="https://github.com/threadexio/zeus"
+arch=('x86_64')
+license=('MIT')
+depends=('docker')
+source=("https://github.com/threadexio/zeus/releases/download/v${pkgver}/zeus-bin.zip")
+sha256sums=('bf74db8dc15c5f4257bb33f8bc237e564d1a7282bd96cca5865474e78738b798')
+conflicts=(zeus)
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 target/release/zeus "$pkgdir"/usr/bin/zeus
+ install -Dm644 builder.tar.gz "$pkgdir"/usr/share/zeus/builder.tar.gz
+ mkdir -p "$pkgdir"/var/cache/aur
+ chmod 0777 "$pkgdir"/var/cache/aur
+}