summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClar Fon2018-12-30 18:47:51 -0500
committerClar Fon2018-12-30 18:47:55 -0500
commitcccb42c3fdac97a121b82392303c6e85fc17898f (patch)
treea19298d7aee24b3a68f4f026f09f0b3347643090
downloadaur-cccb42c3fdac97a121b82392303c6e85fc17898f.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
-rw-r--r--zeyple.install9
-rw-r--r--zeyple.sysusers1
5 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..398382a77f45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = zeyple
+ pkgdesc = Zeyple is a Postfix filter/hook to automatically encrypt outgoing emails with GPG/PGP
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/infertux/zeyple
+ install = zeyple.install
+ arch = any
+ license = AGPL3
+ depends = gnupg
+ depends = python-gpgme
+ source = https://github.com/infertux/zeyple/archive/v1.2.2.tar.gz
+ source = zeyple.sysusers
+ source = zeyple.install
+ sha512sums = 76ae94af969b780ca1085abeb7c815f59d74701d4837fd39af8152ef98bddb5dc10ee137fc303e29202ca26efee0d0c76ffc0633ac14437648c0be3b472eebb7
+ sha512sums = 0db8b837236308fb0da18b5739fb00e64c0858b6a97fb66e605c07c8bb21ebc76c5fa294564af796195faea02177c991b9700db8e92853752110ca119f9e4243
+ sha512sums = e7fa247c07731da1df4e3476aefaec228d86389476b2272e688a651cad3b492b2dbd17d56e9c2e5014fda111abad7def1f340b2b2b25eaaba98699be9c412c4b
+
+pkgname = zeyple
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2b022307d03e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d52b124ec0af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Clar Fon <them@lightdark.xyz>
+
+pkgname=zeyple
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Zeyple is a Postfix filter/hook to automatically encrypt outgoing emails with GPG/PGP"
+arch=('any')
+url="https://github.com/infertux/zeyple"
+license=('AGPL3')
+depends=('gnupg' 'python-gpgme')
+install="zeyple.install"
+source=("https://github.com/infertux/zeyple/archive/v$pkgver.tar.gz"
+ "zeyple.sysusers"
+ "zeyple.install")
+sha512sums=('76ae94af969b780ca1085abeb7c815f59d74701d4837fd39af8152ef98bddb5dc10ee137fc303e29202ca26efee0d0c76ffc0633ac14437648c0be3b472eebb7'
+ '0db8b837236308fb0da18b5739fb00e64c0858b6a97fb66e605c07c8bb21ebc76c5fa294564af796195faea02177c991b9700db8e92853752110ca119f9e4243'
+ 'e7fa247c07731da1df4e3476aefaec228d86389476b2272e688a651cad3b492b2dbd17d56e9c2e5014fda111abad7def1f340b2b2b25eaaba98699be9c412c4b')
+
+package() {
+ install -D -m700 -d "$pkgdir/var/lib/zeyple" "$pkgdir/var/lib/zeyple/keys"
+ install -D -m744 "$srcdir/$pkgname-$pkgver/zeyple/zeyple.py" "$pkgdir/usr/bin/zeyple"
+ install -D -m644 "$srcdir/$pkgname-$pkgver/zeyple/zeyple.conf.example" "$pkgdir/etc/zeyple.conf"
+ install -D -m644 "$srcdir/zeyple.sysusers" "$pkgdir/usr/lib/sysusers.d/zeyple.conf"
+}
diff --git a/zeyple.install b/zeyple.install
new file mode 100644
index 000000000000..ec3c650d588b
--- /dev/null
+++ b/zeyple.install
@@ -0,0 +1,9 @@
+post_install() {
+ touch /var/log/zeyple.log
+ post_upgrade
+}
+
+post_upgrade() {
+ systemd-sysusers /usr/lib/sysusers.d/zeyple.conf
+ chown -R zeyple:zeyple /var/lib/zeyple /usr/bin/zeyple /etc/zeyple.conf /var/log/zeyple.log
+}
diff --git a/zeyple.sysusers b/zeyple.sysusers
new file mode 100644
index 000000000000..07c83b7ddc24
--- /dev/null
+++ b/zeyple.sysusers
@@ -0,0 +1 @@
+u zeyple - "Zeyple user" /var/lib/zeyple