summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArch-Jason2020-07-26 18:28:42 +0800
committerArch-Jason2020-07-26 18:28:42 +0800
commit8b1c25e3820087288c35c8dbeb15a85bf295d335 (patch)
tree625c50aaf13bc544da9b849895635080fef76003
downloadaur-8b1c25e3820087288c35c8dbeb15a85bf295d335.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2de3ccc6c637
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = zff
+ pkgdesc = A simple game
+ pkgver = 5.5.3
+ pkgrel = 1
+ url = https://github.com/ohzff/Zff
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ makedepends = git
+ depends = git
+ depends = wget
+ depends = gcc
+ depends = bash
+ source = git+https://github.com/ohzff/Zff
+ md5sums = SKIP
+
+pkgname = zff
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cdfc2478f69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Arch-Jason <arch-jason@outlook.com>
+pkgname=zff
+pkgver=5.5.3
+pkgrel=1
+pkgdesc="A simple game"
+arch=(x86_64)
+url="https://github.com/ohzff/Zff"
+license=('MIT')
+depends=('git' 'wget' 'gcc' 'bash')
+makedepends=('gcc' 'git')
+source=("git+$url")
+md5sums=("SKIP")
+
+prepare() {
+ cd Zff
+}
+
+build() {
+ cd Zff
+ g++ zff_main_en.cpp -o zff
+}
+
+package() {
+ cd Zff
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/share/ohzff-zff"
+ install -m775 zff "$pkgdir/usr/bin/zff"
+ cd ../
+ cp -r Zff/* "$pkgdir/usr/share/ohzff-zff"
+}