summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-11-08 21:05:20 +0100
committerMichel Zou2018-11-08 21:05:20 +0100
commitf03862afb49a07ff704e73cb1b3510e285c9a083 (patch)
tree613261c21cbcc6e038acf17021fe534389d4a468
downloadaur-f03862afb49a07ff704e73cb1b3510e285c9a083.tar.gz
0.5.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97ea310794ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = zfp
+ pkgdesc = Library for compressed numerical array
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = https://computation.llnl.gov/projects/floating-point-compression
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = gcc-libs
+ source = https://github.com/LLNL/zfp/releases/download/0.5.4/zfp-0.5.4.tar.gz
+ sha256sums = 746e17aaa401c67dcffd273d6e6f95c76adfbbd5cf523dcad56d09e9d3b71196
+
+pkgname = zfp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b7edc76c7f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=zfp
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Library for compressed numerical array"
+arch=('x86_64')
+url="https://computation.llnl.gov/projects/floating-point-compression"
+license=('BSD')
+depends=('gcc-libs')
+makedepends=('cmake')
+source=("https://github.com/LLNL/zfp/releases/download/$pkgver/zfp-$pkgver.tar.gz")
+sha256sums=('746e17aaa401c67dcffd273d6e6f95c76adfbbd5cf523dcad56d09e9d3b71196')
+
+build() {
+ cd "$srcdir/zfp-$pkgver"
+ mkdir -p build && pushd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib ..
+ make
+}
+
+check() {
+ cd "$srcdir/zfp-$pkgver/build"
+ ctest --output-on-failure
+}
+
+package() {
+ cd "$srcdir/zfp-$pkgver/build"
+ make DESTDIR="$pkgdir" install
+}
+