summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2016-06-13 01:36:04 -0700
committerJesus Alvarez2016-06-13 01:36:04 -0700
commit016bae471837af56f3627d59b52303fb1999806a (patch)
treef2aca5e44b810ba8151972f1f26565710f860a44
downloadaur-016bae471837af56f3627d59b52303fb1999806a.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
-rw-r--r--zfs.install27
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e22199b58db6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Jun 13 08:25:27 UTC 2016
+pkgbase = zfs-archiso-linux
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ pkgver = 0.6.5.7_4.5.4_1
+ pkgrel = 1
+ url = http://zfsonlinux.org/
+ install = zfs.install
+ arch = x86_64
+ groups = archzfs-archiso-linux
+ license = CDDL
+ makedepends = linux-headers=4.5.4
+ depends = kmod
+ depends = spl-archiso-linux
+ depends = zfs-utils-archiso-linux
+ depends = linux=4.5.4
+ provides = zfs
+ source = http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/zfs-0.6.5.7.tar.gz
+ sha256sums = 4a9e271bb9a6af8d564e4d5800e4fff36224f1697b923a7253659bdda80dc590
+
+pkgname = zfs-archiso-linux
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1df2e29bbe7d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+*.sig
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4975d2b580e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-archiso-linux packages will only work with the archiso ISO! To have a single PKGBUILD target many kernels
+# would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+#
+pkgname="zfs-archiso-linux"
+pkgver=0.6.5.7_4.5.4_1
+pkgrel=1
+pkgdesc="Kernel modules for the Zettabyte File System."
+depends=("kmod" "spl-archiso-linux" "zfs-utils-archiso-linux" "linux=4.5.4")
+makedepends=("linux-headers=4.5.4")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/zfs-0.6.5.7.tar.gz")
+sha256sums=("4a9e271bb9a6af8d564e4d5800e4fff36224f1697b923a7253659bdda80dc590")
+groups=("archzfs-archiso-linux")
+license=("CDDL")
+install=zfs.install
+provides=("zfs")
+
+build() {
+ cd "${srcdir}/zfs-0.6.5.7"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
+ --datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
+ --libexecdir=/usr/lib/zfs-0.6.5.7 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.5.4-1-ARCH/build
+ make
+}
+
+package() {
+ cd "${srcdir}/zfs-0.6.5.7"
+ make DESTDIR="${pkgdir}" install
+ cp -r "${pkgdir}"/{lib,usr}
+ rm -r "${pkgdir}"/lib
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.5.4-1-ARCH/Module.symvers
+}
diff --git a/zfs.install b/zfs.install
new file mode 100644
index 000000000000..25a201ce46d4
--- /dev/null
+++ b/zfs.install
@@ -0,0 +1,27 @@
+post_install() {
+ check_initramfs
+}
+
+post_remove() {
+ check_initramfs 'remove'
+}
+
+post_upgrade() {
+ check_initramfs
+}
+
+check_initramfs() {
+ echo ">>> Updating ZFS module dependencies"
+ depmod -a 4.5.4-1-ARCH
+ MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
+ if [[ ${MK_CONF} == '0' ]]; then
+ if [[ $1 == 'remove' ]]; then
+ echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
+ echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
+ echo '>>> "hooks" list and then regenerate the initial ramdisk.'
+ else
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p archiso
+ fi
+ fi
+}