summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchzfs Buildbot2018-11-11 04:53:14 +0000
committerArchzfs Buildbot2018-11-11 04:53:14 +0000
commit1cdc8d95ba4d6115be5ab238172c0b81625fff49 (patch)
tree7635279b35c0f727fc35320375d39e0cc6aa7908
parent0ec39a5674b6c7cf5ec1d4d9f652869c0bae0b73 (diff)
downloadaur-1cdc8d95ba4d6115be5ab238172c0b81625fff49.tar.gz
Semi-automated update for kernel 4.18.16.arch1-1 + zfs 0.7.11
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD36
-rw-r--r--zfs.install14
3 files changed, 32 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1feb6b4a4604..1d35b0a69a38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,30 @@
-# Generated by mksrcinfo v8
-# Tue Oct 3 18:49:53 UTC 2017
pkgbase = zfs-archiso-linux
- pkgver = 0.7.2_4.13.3.1
+ pkgver = 0.7.11_4.18.16.arch1.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.13.3
+ makedepends = linux-headers=4.18.16.arch1-1
makedepends = spl-archiso-linux-headers
depends = kmod
depends = spl-archiso-linux
- depends = zfs-utils-common>=0.7.2
- depends = linux=4.13.3
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.2/zfs-0.7.2.tar.gz
- sha256sums = f75f4d8bbb8241e3d06321b53914e53fa22d1ccc8be89819b578b46e5d3e5cf4
+ depends = zfs-utils=0.7.11
+ depends = linux=4.18.16.arch1-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.11/zfs-0.7.11.tar.gz
+ sha256sums = 4dff9ecce6e02061242d9435febe88c1250de83b96d392b712bccf31c459517a
pkgname = zfs-archiso-linux
pkgdesc = Kernel modules for the Zettabyte File System.
install = zfs.install
groups = archzfs-archiso-linux
provides = zfs
- conflicts =
+ conflicts = zfs-dkms
+ conflicts = zfs-dkms-git
pkgname = zfs-archiso-linux-headers
pkgdesc = Kernel headers for the Zettabyte File System.
- conflicts = zfs-linux-hardened-headers
- conflicts = zfs-linux-hardened-git-headers
- conflicts = zfs-linux-lts-headers
- conflicts = zfs-linux-lts-git-headers
- conflicts = zfs-linux-headers
- conflicts = zfs-linux-git-headers
- conflicts = zfs-linux-zen-headers
- conflicts = zfs-linux-zen-git-headers
+ provides = zfs-headers
+ conflicts = zfs-headers
+ conflicts = zfs-dkms
+ conflicts = zfs-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index 500a1efab4e8..c7812abac27b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+# Maintainer: Jan Houben <jan@nexttrex.de>
+# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
#
# This PKGBUILD was generated by the archzfs build scripts located at
#
@@ -14,28 +15,30 @@
# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
# archzfs github page.
#
-#
pkgbase="zfs-archiso-linux"
pkgname=("zfs-archiso-linux" "zfs-archiso-linux-headers")
+_zfsver="0.7.11"
+_kernelver="4.18.16.arch1-1"
+_extramodules="${_kernelver/.arch/-arch}-ARCH"
-pkgver=0.7.2_4.13.3.1
+pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
pkgrel=1
-makedepends=("linux-headers=4.13.3" "spl-archiso-linux-headers")
+makedepends=("linux-headers=${_kernelver}" "spl-archiso-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.2/zfs-0.7.2.tar.gz")
-sha256sums=("f75f4d8bbb8241e3d06321b53914e53fa22d1ccc8be89819b578b46e5d3e5cf4")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_zfsver}/zfs-${_zfsver}.tar.gz")
+sha256sums=("4dff9ecce6e02061242d9435febe88c1250de83b96d392b712bccf31c459517a")
license=("CDDL")
-depends=("kmod" "spl-archiso-linux" "zfs-utils-common>=0.7.2" "linux=4.13.3")
+depends=("kmod" 'spl-archiso-linux' "zfs-utils=${_zfsver}" "linux=${_kernelver}")
build() {
- cd "${srcdir}/zfs-0.7.2"
+ cd "${srcdir}/zfs-${_zfsver}"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.2 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.13.3-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.13.3-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-${zfsver} --with-config=kernel \
+ --with-linux=/usr/lib/modules/${_extramodules}/build \
+ --with-linux-obj=/usr/lib/modules/${_extramodules}/build
make
}
@@ -44,8 +47,8 @@ package_zfs-archiso-linux() {
install=zfs.install
provides=("zfs")
groups=("archzfs-archiso-linux")
- conflicts=()
- cd "${srcdir}/zfs-0.7.2"
+ conflicts=("zfs-dkms" "zfs-dkms-git")
+ cd "${srcdir}/zfs-${_zfsver}"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -55,10 +58,11 @@ package_zfs-archiso-linux() {
package_zfs-archiso-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=( 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.2"
+ provides=("zfs-headers")
+ conflicts=("zfs-headers" "zfs-dkms" "zfs-dkms-git")
+ cd "${srcdir}/zfs-${_zfsver}"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.3-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/${_extramodules}/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 7bd48d8f789a..c2a2d7807e6d 100644
--- a/zfs.install
+++ b/zfs.install
@@ -1,18 +1,4 @@
-post_install() {
- check_initramfs
-}
-
post_remove() {
- check_initramfs 'remove'
-}
-
-post_upgrade() {
- check_initramfs
-}
-
-check_initramfs() {
- echo ">>> Updating ZFS module dependencies"
- depmod -a 4.13.3-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'