summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-01 22:25:40 -0700
committerJesus Alvarez2017-08-01 22:25:40 -0700
commit329491ce5cde508467a01e93664116840f6131d2 (patch)
tree120d12fc09a659db62bbd05a73a47af47de91973
parente08a44558571c89b57d034a764d75c76f910ecda (diff)
downloadaur-329491ce5cde508467a01e93664116840f6131d2.tar.gz
Semi-automated update for 4.12.3_1-1
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD46
-rw-r--r--zfs.install15
3 files changed, 56 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d407a4c7e3e..1a0f4e48c3df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,33 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 05:22:54 UTC 2016
+# Wed Aug 2 05:24:56 UTC 2017
pkgbase = zfs-archiso-linux
- pkgdesc = Kernel modules for the Zettabyte File System.
- pkgver = 0.6.5.8_4.7.2_1
+ pkgver = 0.7.0_4.12.3_1
pkgrel = 1
url = http://zfsonlinux.org/
- install = zfs.install
arch = x86_64
- groups = archzfs-archiso-linux
license = CDDL
- makedepends = linux-headers=4.7.2
+ makedepends = linux-headers=4.12.3
+ makedepends = spl-archiso-linux-headers
depends = kmod
depends = spl-archiso-linux
- depends = zfs-utils-archiso-linux
- depends = linux=4.7.2
- provides = zfs
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.8/zfs-0.6.5.8.tar.gz
- sha256sums = d77f43f7dc38381773e2c34531954c52f3de80361b7bb10c933a7482f89cfe84
+ depends = zfs-utils-common>=0.7.0
+ depends = linux=4.12.3
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz
+ sha256sums = 6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2
pkgname = zfs-archiso-linux
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ install = zfs.install
+ groups = archzfs-archiso-linux
+ provides = zfs
+ conflicts =
+
+pkgname = zfs-archiso-linux-headers
+ pkgdesc = Kernel headers for the Zettabyte File System.
+ conflicts = zfs-linux-hardened-headers
+ conflicts = zfs-linux-hardened-git-headers
+ conflicts = zfs-linux-lts-headers
+ conflicts = zfs-linux-lts-git-headers
+ conflicts = zfs-linux-headers
+ conflicts = zfs-linux-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index feae1f3831d3..23e08e271e28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,37 +15,49 @@
# archzfs github page.
#
#
-pkgname="zfs-archiso-linux"
-pkgver=0.6.5.8_4.7.2_1
+pkgbase="zfs-archiso-linux"
+pkgname=("zfs-archiso-linux" "zfs-archiso-linux-headers")
+pkgver=0.7.0_4.12.3_1
pkgrel=1
-pkgdesc="Kernel modules for the Zettabyte File System."
-depends=("kmod" "spl-archiso-linux" "zfs-utils-archiso-linux" "linux=4.7.2")
-makedepends=("linux-headers=4.7.2")
+makedepends=("linux-headers=4.12.3" "spl-archiso-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.8/zfs-0.6.5.8.tar.gz")
-sha256sums=("d77f43f7dc38381773e2c34531954c52f3de80361b7bb10c933a7482f89cfe84")
-groups=("archzfs-archiso-linux")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz")
+sha256sums=("6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2")
license=("CDDL")
-install=zfs.install
-provides=("zfs")
+depends=("kmod" "spl-archiso-linux" "zfs-utils-common>=0.7.0" "linux=4.12.3")
build() {
- cd "${srcdir}/zfs-0.6.5.8"
+ cd "${srcdir}/zfs-0.7.0"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.6.5.8 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.7.2-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.7.2-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.0 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.12.3-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.12.3-1-ARCH/build
make
}
-package() {
- cd "${srcdir}/zfs-0.6.5.8"
+package_zfs-archiso-linux() {
+ pkgdesc="Kernel modules for the Zettabyte File System."
+ install=zfs.install
+ provides=("zfs")
+ groups=("archzfs-archiso-linux")
+ conflicts=()
+ cd "${srcdir}/zfs-0.7.0"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_zfs-archiso-linux-headers() {
+ pkgdesc="Kernel headers for the Zettabyte File System."
+ conflicts=( 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ cd "${srcdir}/zfs-0.7.0"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.7.2-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.3-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 71bd0eab0b38..7e1ba1655196 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,16 +12,11 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.7.2-1-ARCH
+ depmod -a 4.12.3-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
- if [[ ${MK_CONF} == '0' ]]; then
- if [[ $1 == 'remove' ]]; then
- echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
- echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
- echo '>>> "hooks" list and then regenerate the initial ramdisk.'
- else
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p archiso
- fi
+ if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
+ echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
+ echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
+ echo '>>> "hooks" list and then regenerate the initial ramdisk.'
fi
}