summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBin Jin2015-10-16 21:58:09 +0200
committerBin Jin2015-10-16 21:58:09 +0200
commita53ecefa09d8f105ff09c7a0d2f283aaddcaf59e (patch)
tree9b9ca04a22262c489191d66da589066b65c4b069
parent0b1dd601dac872a933c62fb984b3bd50ec9980df (diff)
downloadaur-a53ecefa09d8f105ff09c7a0d2f283aaddcaf59e.tar.gz
add instructions, bump release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD3
-rw-r--r--zfs.install26
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7569e8841a1..860de13beb6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zfs-dkms-git
pkgver = 0.6.5.3_r0_g9aaf60b
- pkgrel = 1
+ pkgrel = 2
url = http://zfsonlinux.org/
arch = i686
arch = x86_64
@@ -20,7 +20,7 @@ pkgname = zfs-dkms-git
pkgdesc = Kernel modules for the Zettabyte File System.
install = zfs.install
depends = spl-dkms-git
- depends = zfs-utils-dkms-git=0.6.5.3_r0_g9aaf60b-1
+ depends = zfs-utils-dkms-git=0.6.5.3_r0_g9aaf60b-2
depends = dkms
provides = zfs-dkms
conflicts = zfs-git
diff --git a/PKGBUILD b/PKGBUILD
index 2c96ea05d032..480d0e897f60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase="zfs-dkms-git"
pkgname=("zfs-dkms-git" "zfs-utils-dkms-git")
pkgver=0.6.5.3_r0_g9aaf60b
-pkgrel=1
+pkgrel=2
license=('CDDL')
makedepends=("git" "tar")
arch=("i686" "x86_64")
@@ -58,6 +58,7 @@ package_zfs-dkms-git() {
cd "${dkmsdir}"
./autogen.sh
scripts/dkms.mkconf -v ${pkgver%%_*} -f dkms.conf -n zfs
+ chmod g-w,o-w -R .
}
package_zfs-utils-dkms-git() {
diff --git a/zfs.install b/zfs.install
index 996a4577e320..cd9d85433769 100644
--- a/zfs.install
+++ b/zfs.install
@@ -1,15 +1,37 @@
post_install() {
dkms add zfs/${1%%[-_]*}
+ cat << EOF
+==> To build and install your modules run: dkms install zfs/${1%%[_-]*} -k [KERNEL]
+==> To do this automatically at startup run: systemctl enable dkms.service
+EOF
+ check_initramfs "install"
}
pre_upgrade() {
- pre_remove ${2%%[-_]*}
+ pre_remove "$2"
}
post_upgrade() {
- post_install ${1%%[-_]*}
+ post_install "$1"
}
pre_remove() {
[ -n "${1%%[-_]*}" ] && dkms remove zfs/${1%%[-_]*} --all &>/dev/null || true
}
+
+post_remove() {
+ check_initramfs "remove"
+}
+
+check_initramfs() {
+ if grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; then
+ if [[ $1 == 'remove' ]]; then
+ echo '==> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
+ echo '==> list in mkinitcpio.conf! You will need to remove "zfs" from the '
+ echo '==> "hooks" list and then regenerate the initial ramdisk.'
+ else
+ echo '==> The ZFS packages are installed/updated, you need to (re)generate initial ramdisk yourself'
+ echo '==> After modules are built and installed, run: mkinitcpio -p [PRESET]'
+ fi
+ fi
+}