summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuhaiha2020-04-10 10:10:20 +0200
committerMuhaiha2020-04-10 10:10:20 +0200
commitc42d68e2e99f81cdd98415b1d2f42dc8762185e9 (patch)
tree843b0714483c97a70d75e2d2f3ffe85d822cec8b
downloadaur-c42d68e2e99f81cdd98415b1d2f42dc8762185e9.tar.gz
Update package
-rw-r--r--.SRCINFO27
-rw-r--r--0001-only-build-the-module-in-dkms.conf.patch49
-rw-r--r--PKGBUILD68
3 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0b6e25f06f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = zfs-dkms-git-any
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ pkgver = 0.8.0.r709.g5a42ef04f
+ pkgrel = 1
+ epoch = 1
+ url = https://zfsonlinux.org/
+ arch = any
+ license = CDDL
+ makedepends = git
+ depends = zfs-utils-git-any
+ depends = dkms
+ provides = zfs-dkms-git
+ provides = zfs-dkms
+ provides = zfs
+ conflicts = zfs-dkms-git
+ conflicts = zfs-dkms
+ replaces = zfs-dkms-git
+ replaces = zfs-dkms
+ source = git+https://github.com/zfsonlinux/zfs.git
+ source = 0001-only-build-the-module-in-dkms.conf.patch
+ sha256sums = SKIP
+ sha256sums = 780e590383fb00389c5e02ac15709b7a476d9e07d3c4935ed9eb67c951a88409
+ b2sums = SKIP
+ b2sums = 1fdae935043d979b9241f07f8baa25a9a0367c24c31c84a59dfe8d6b468a523d8f49b68da3c7fd3194db6638f9d7bef046fc5e2669ce25d73c65009c16bf6c50
+
+pkgname = zfs-dkms-git-any
+
diff --git a/0001-only-build-the-module-in-dkms.conf.patch b/0001-only-build-the-module-in-dkms.conf.patch
new file mode 100644
index 000000000000..0e162b5db1fa
--- /dev/null
+++ b/0001-only-build-the-module-in-dkms.conf.patch
@@ -0,0 +1,49 @@
+From b4a2c0b184c9c9599421b15a430fb88deb5dbd17 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@archlinux.org>
+Date: Sun, 28 Oct 2018 15:01:58 -0400
+Subject: [PATCH] only build the module in dkms.conf
+
+---
+ scripts/dkms.mkconf | 19 ++-----------------
+ 1 file changed, 2 insertions(+), 17 deletions(-)
+
+diff --git a/scripts/dkms.mkconf b/scripts/dkms.mkconf
+index 88c289383..5a859a0e0 100755
+--- a/scripts/dkms.mkconf
++++ b/scripts/dkms.mkconf
+@@ -25,22 +25,7 @@ PACKAGE_CONFIG="${pkgcfg}"
+ PRE_BUILD="configure
+ --prefix=/usr
+ --with-config=kernel
+- --with-linux=\$(
+- case \`lsb_release -is\` in
+- (Debian|Devuan)
+- if [[ -e \${kernel_source_dir/%build/source} ]]
+- then
+- echo \${kernel_source_dir/%build/source}
+- else
+- # A kpkg exception for Proxmox 2.0
+- echo \${kernel_source_dir}
+- fi
+- ;;
+- (*)
+- echo \${kernel_source_dir}
+- ;;
+- esac
+- )
++ --with-linux=\${kernel_source_dir}
+ --with-linux-obj=\${kernel_source_dir}
+ --with-spl=\${source_tree}/spl-\${PACKAGE_VERSION}
+ --with-spl-obj=\${dkms_tree}/spl/\${PACKAGE_VERSION}/\${kernelver}/\${arch}
+@@ -78,7 +63,7 @@ POST_BUILD="scripts/dkms.postbuild
+ BUILD_DEPENDS[0]="spl"
+ AUTOINSTALL="yes"
+ REMAKE_INITRD="no"
+-MAKE[0]="make"
++MAKE[0]="make -C module/"
+ STRIP[0]="\$(
+ [[ -r \${PACKAGE_CONFIG} ]] \\
+ && source \${PACKAGE_CONFIG} \\
+--
+2.19.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13692fc5edf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+# Contributor: Iacopo Isimbaldi <isiachi@rhye.it>
+
+# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
+
+pkgname=zfs-dkms-git-any
+pkgver=0.8.0.r709.g5a42ef04f
+pkgrel=1
+epoch=1
+pkgdesc="Kernel modules for the Zettabyte File System."
+arch=('any')
+url="https://zfsonlinux.org/"
+depends=("zfs-utils-git-any" "dkms")
+license=('CDDL')
+makedepends=('git')
+conflicts=("zfs-dkms-git" "zfs-dkms")
+provides=("zfs-dkms-git" "zfs-dkms")
+# ambiguous, provided for backwards compat, pls don't use
+provides+=('zfs')
+replaces=("zfs-dkms-git" "zfs-dkms")
+source=("git+https://github.com/zfsonlinux/zfs.git"
+ "0001-only-build-the-module-in-dkms.conf.patch")
+sha256sums=('SKIP'
+ '780e590383fb00389c5e02ac15709b7a476d9e07d3c4935ed9eb67c951a88409')
+b2sums=('SKIP'
+ '1fdae935043d979b9241f07f8baa25a9a0367c24c31c84a59dfe8d6b468a523d8f49b68da3c7fd3194db6638f9d7bef046fc5e2669ce25d73c65009c16bf6c50')
+
+pkgver() {
+ cd "${srcdir}"/zfs
+
+ git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}"/zfs
+
+ patch -p1 -i ../0001-only-build-the-module-in-dkms.conf.patch
+
+ # remove unneeded sections from module build
+ sed -ri "/AC_CONFIG_FILES/,/]\)/{
+/AC_CONFIG_FILES/n
+/]\)/n
+/^\s*(module\/.*)?(zfs.release|Makefile)/!d
+}" configure.ac
+
+ autoreconf -fi
+}
+
+build() {
+ cd "${srcdir}"/zfs
+
+ ./scripts/dkms.mkconf -n zfs -v ${pkgver} -f dkms.conf
+ # update metadata
+ ./scripts/make_gitrev.sh
+ _meta_release=${pkgver#*.r}
+ sed -i -e "s/Release:[[:print:]]*/Release: ${_meta_release/./_}/" META
+}
+
+package() {
+
+ cd "${srcdir}"/zfs
+
+ dkmsdir="${pkgdir}/usr/src/zfs-${pkgver}"
+ install -d "${dkmsdir}"/{config,scripts}
+ cp -a configure dkms.conf Makefile.in META zfs_config.h.in zfs.release.in include/ module/ "${dkmsdir}"/
+ cp config/config.* config/missing config/*sh "${dkmsdir}"/config/
+ cp scripts/enum-extract.pl scripts/dkms.postbuild "${dkmsdir}"/scripts/
+}