summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Houben2020-11-01 13:03:06 -0500
committerJan Houben2020-11-01 13:03:06 -0500
commitfe89d6cc4adc123ab36abae41dbc7a535eb850d3 (patch)
tree492bb5fd744b46098d8d819e113350c9ca0f9d8e
parentfd4a81e077148b03e3a9ec6dae7a9df16af21c0b (diff)
downloadaur-fe89d6cc4adc123ab36abae41dbc7a535eb850d3.tar.gz
Update to 2.0.0 rc4
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD81
-rw-r--r--zfs.bash-completion-r1391
-rw-r--r--zfs.initcpio.hook119
-rw-r--r--zfs.initcpio.install109
6 files changed, 42 insertions, 711 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d1372610863..eaa9180080f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,24 @@
pkgbase = zfs-dkms-rc
- pkgver = 0.8.0
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ pkgver = 2.0.0_rc4
pkgrel = 1
- url = http://zfsonlinux.org/
- arch = i686
+ url = https://zfsonlinux.org/
arch = x86_64
+ groups = archzfs-dkms-rc
license = CDDL
- makedepends = git
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.8.0/zfs-0.8.0.tar.gz
- source = zfs.bash-completion-r1
- source = zfs.initcpio.install
- source = zfs.initcpio.hook
- sha256sums = 0fd92e87f4b9df9686f18e2ac707c16b2eeaf00f682d41c20ea519f3a0fe4705
- sha256sums = b60214f70ffffb62ffe489cbfabd2e069d14ed2a391fac0e36f914238394b540
- sha256sums = 17114052aa20c528f022f7f1349971aa28810e2ed2c97871226b5679a91f7e77
- sha256sums = 138964b43d7a282e1ed5f7fcf1f8dc9baa4f664655b628eeac1912a3017a787b
-
-pkgname = zfs-dkms-rc
- pkgdesc = Kernel modules for the Zettabyte File System -- release candidates
- depends = zfs-utils-rc=0.8.0-1
- depends = dkms
+ depends = zfs-utils-rc=2.0.0_rc4
depends = lsb-release
+ depends = dkms
provides = zfs
- conflicts = zfs-git
- conflicts = zfs-lts
- conflicts = zfs-dkms
+ provides = zfs-headers
+ provides = spl
+ provides = spl-headers
+ conflicts = zfs
+ conflicts = zfs-headers
+ conflicts = spl
+ conflicts = spl-headers
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-2.0.0-rc4/zfs-2.0.0-rc4.tar.gz
+ sha256sums = d89838d93b4429de98075de1a7fcac4b22673cedab4e9b109594f9f8c2456c51
-pkgname = zfs-utils-rc
- pkgdesc = Kernel module support files for the Zettabyte File System -- release candidates
- conflicts = zfs-utils-git
- conflicts = zfs-utils-lts
- conflicts = zfs-dkms
+pkgname = zfs-dkms-rc
diff --git a/.gitignore b/.gitignore
index 5d372660dcf7..33c98cc0fdd3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,5 @@
-!.gitignore
-
-/src
-/pkg
-*.pkg*
-*.orig
-zfs-*.tar.gz
+*.tar.xz
+*.tar.gz
+*.tar.zst
+*.sig
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index c564cdd89d45..4fe6e3914cfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,76 +1,37 @@
+# Maintainer: Jan Houben <jan@nexttrex.de>
+# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
#
-# Maintainer: Grey Christoforo <first name at last name dot net>
+# This PKGBUILD was generated by the archzfs build scripts located at
#
+# http://github.com/archzfs/archzfs
+#
+pkgname="zfs-dkms-rc"
+pkgdesc="Kernel modules for the Zettabyte File System."
-pkgbase="zfs-dkms-rc"
-pkgname=("zfs-dkms-rc" "zfs-utils-rc")
-_pkgver=0.8.0
-_pkgver_base=${_pkgver%-*}
-pkgver=${_pkgver//-rc/.}
+pkgver=2.0.0_rc4
pkgrel=1
-license=('CDDL')
-makedepends=("git")
-arch=("i686" "x86_64")
-url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_pkgver}/zfs-${_pkgver}.tar.gz"
- "zfs.bash-completion-r1"
- "zfs.initcpio.install"
- "zfs.initcpio.hook")
-sha256sums=('0fd92e87f4b9df9686f18e2ac707c16b2eeaf00f682d41c20ea519f3a0fe4705'
- 'b60214f70ffffb62ffe489cbfabd2e069d14ed2a391fac0e36f914238394b540'
- '17114052aa20c528f022f7f1349971aa28810e2ed2c97871226b5679a91f7e77'
- '138964b43d7a282e1ed5f7fcf1f8dc9baa4f664655b628eeac1912a3017a787b')
+makedepends=()
+arch=("x86_64")
+url="https://zfsonlinux.org/"
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver/_/-}/zfs-${pkgver/_/-}.tar.gz")
+sha256sums=("d89838d93b4429de98075de1a7fcac4b22673cedab4e9b109594f9f8c2456c51")
+license=("CDDL")
+depends=("zfs-utils-rc=${pkgver}" "lsb-release" "dkms")
+provides=("zfs" "zfs-headers" "spl" "spl-headers")
+groups=("archzfs-dkms-rc")
+conflicts=("zfs" "zfs-headers" "spl" "spl-headers")
build() {
- cd "${srcdir}/zfs-${_pkgver_base}"
+ cd "${srcdir}/zfs-${pkgver/_rc*/}"
./autogen.sh
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --sbindir=/usr/bin \
- --with-mounthelperdir=/usr/bin \
- --libdir=/usr/lib \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --with-udevdir=/usr/lib/udev \
- --libexecdir=/usr/lib/zfs \
- --with-config=user
- make
}
-package_zfs-dkms-rc() {
- pkgdesc="Kernel modules for the Zettabyte File System -- release candidates"
- depends=("zfs-utils-rc=${pkgver}-${pkgrel}" "dkms" "lsb-release")
- provides=("zfs")
- conflicts=("zfs-git" "zfs-lts" "zfs-dkms")
-
+package() {
dkmsdir="${pkgdir}/usr/src/zfs-${pkgver}"
install -d "${dkmsdir}"
- cp -a "${srcdir}/zfs-${_pkgver_base}/." ${dkmsdir}
-
+ cp -a ${srcdir}/zfs-${pkgver/_rc*/}/. ${dkmsdir}
cd "${dkmsdir}"
- make clean
- make distclean
find . -name ".git*" -print0 | xargs -0 rm -fr --
scripts/dkms.mkconf -v ${pkgver} -f dkms.conf -n zfs
chmod g-w,o-w -R .
}
-
-package_zfs-utils-rc() {
- pkgdesc="Kernel module support files for the Zettabyte File System -- release candidates"
- conflicts=("zfs-utils-git" "zfs-utils-lts" "zfs-dkms")
-
- cd "${srcdir}/zfs-${_pkgver_base}"
- make DESTDIR="${pkgdir}" install
-
- # Remove uneeded files
- rm -r "${pkgdir}"/etc/init.d
- rm -r "${pkgdir}"/usr/lib/dracut
- rm -r "${pkgdir}"/usr/share/initramfs-tools
-
- install -D -m644 "${srcdir}"/zfs.initcpio.hook "${pkgdir}"/usr/lib/initcpio/hooks/zfs
- install -D -m644 "${srcdir}"/zfs.initcpio.install "${pkgdir}"/usr/lib/initcpio/install/zfs
- install -D -m644 "${srcdir}"/zfs.bash-completion-r1 "${pkgdir}"/usr/share/bash-completion/completions/zfs
-
- mkdir -p "${pkgdir}"/usr/lib/initcpio/install
-}
diff --git a/zfs.bash-completion-r1 b/zfs.bash-completion-r1
deleted file mode 100644
index b1aded368e85..000000000000
--- a/zfs.bash-completion-r1
+++ /dev/null
@@ -1,391 +0,0 @@
-# Copyright (c) 2013, Aneurin Price <aneurin.price@gmail.com>
-
-# Permission is hereby granted, free of charge, to any person
-# obtaining a copy of this software and associated documentation
-# files (the "Software"), to deal in the Software without
-# restriction, including without limitation the rights to use,
-# copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the
-# Software is furnished to do so, subject to the following
-# conditions:
-
-# The above copyright notice and this permission notice shall be
-# included in all copies or substantial portions of the Software.
-
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
-# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
-# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
-# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-# OTHER DEALINGS IN THE SOFTWARE.
-
-#if [[ -w /dev/zfs ]]; then
- __ZFS_CMD="zfs"
- __ZPOOL_CMD="zpool"
-#else
-# __ZFS_CMD="sudo zfs"
-# __ZPOOL_CMD="sudo zpool"
-#fi
-
-__zfs_get_commands()
-{
- $__ZFS_CMD 2>&1 | awk '/^\t[a-z]/ {print $1}' | cut -f1 -d '|' | uniq
-}
-
-__zfs_get_properties()
-{
- $__ZFS_CMD get 2>&1 | awk '$2 == "YES" || $2 == "NO" {print $1}'; echo all name space
-}
-
-__zfs_get_editable_properties()
-{
- $__ZFS_CMD get 2>&1 | awk '$2 == "YES" {print $1"="}'
-}
-
-__zfs_get_inheritable_properties()
-{
- $__ZFS_CMD get 2>&1 | awk '$3 == "YES" {print $1}'
-}
-
-__zfs_list_datasets()
-{
- $__ZFS_CMD list -H -o name -t filesystem,volume
-}
-
-__zfs_list_filesystems()
-{
- $__ZFS_CMD list -H -o name -t filesystem
-}
-
-__zfs_match_snapshot()
-{
- local base_dataset=${cur%@*}
- if [[ $base_dataset != $cur ]]
- then
- $__ZFS_CMD list -H -o name -t snapshot -d 1 $base_dataset
- else
- $__ZFS_CMD list -H -o name -t filesystem,volume | awk '{print $1"@"}'
- fi
-}
-
-__zfs_match_explicit_snapshot()
-{
- local base_dataset=${cur%@*}
- if [[ $base_dataset != $cur ]]
- then
- $__ZFS_CMD list -H -o name -t snapshot -d 1 $base_dataset
- fi
-}
-
-__zfs_match_multiple_snapshots()
-{
- local existing_opts=$(expr "$cur" : '\(.*\)[%,]')
- if [[ $existing_opts ]]
- then
- local base_dataset=${cur%@*}
- if [[ $base_dataset != $cur ]]
- then
- local cur=${cur##*,}
- if [[ $cur =~ ^%|%.*% ]]
- then
- # correct range syntax is start%end
- return 1
- fi
- local range_start=$(expr "$cur" : '\(.*%\)')
- $__ZFS_CMD list -H -o name -t snapshot -d 1 $base_dataset | sed 's$.*@$'$range_start'$g'
- fi
- else
- __zfs_match_explicit_snapshot; __zfs_list_datasets
- fi
-}
-
-__zfs_list_volumes()
-{
- $__ZFS_CMD list -H -o name -t volume
-}
-
-__zfs_argument_chosen()
-{
- local word property
- for word in $(seq $((COMP_CWORD-1)) -1 2)
- do
- local prev="${COMP_WORDS[$word]}"
- if [[ ${COMP_WORDS[$word-1]} != -[tos] ]]
- then
- if [[ "$prev" == [^,]*,* ]] || [[ "$prev" == *[@:]* ]]
- then
- return 0
- fi
- for property in $@
- do
- if [[ $prev == "$property" ]]
- then
- return 0
- fi
- done
- fi
- done
- return 1
-}
-
-__zfs_complete_ordered_arguments()
-{
- local list1=$1
- local list2=$2
- local cur=$3
- local extra=$4
- if __zfs_argument_chosen $list1
- then
- COMPREPLY=($(compgen -W "$list2 $extra" -- "$cur"))
- else
- COMPREPLY=($(compgen -W "$list1 $extra" -- "$cur"))
- fi
-}
-
-__zfs_complete_multiple_options()
-{
- local options=$1
- local cur=$2
-
- COMPREPLY=($(compgen -W "$options" -- "${cur##*,}"))
- local existing_opts=$(expr "$cur" : '\(.*,\)')
- if [[ $existing_opts ]]
- then
- COMPREPLY=( "${COMPREPLY[@]/#/${existing_opts}}" )
- fi
-}
-
-__zfs_complete_switch()
-{
- local options=$1
- if [[ ${cur:0:1} == - ]]
- then
- COMPREPLY=($(compgen -W "-{$options}" -- "$cur"))
- return 0
- else
- return 1
- fi
-}
-
-__zfs_complete()
-{
- local cur prev cmd cmds
- COMPREPLY=()
- # Don't split on colon
- _get_comp_words_by_ref -n : -c cur -p prev -w COMP_WORDS -i COMP_CWORD
- cmd="${COMP_WORDS[1]}"
-
- if [[ ${prev##*/} == zfs ]]
- then
- cmds=$(__zfs_get_commands)
- COMPREPLY=($(compgen -W "$cmds -?" -- "$cur"))
- return 0
- fi
-
- case "${cmd}" in
- clone)
- case "${prev}" in
- -o)
- COMPREPLY=($(compgen -W "$(__zfs_get_editable_properties)" -- "$cur"))
- ;;
- *)
- if ! __zfs_complete_switch "o,p"
- then
- if __zfs_argument_chosen
- then
- COMPREPLY=($(compgen -W "$(__zfs_list_datasets)" -- "$cur"))
- else
- COMPREPLY=($(compgen -W "$(__zfs_match_snapshot)" -- "$cur"))
- fi
- fi
- ;;
- esac
- ;;
- get)
- case "${prev}" in
- -d)
- COMPREPLY=($(compgen -W "" -- "$cur"))
- ;;
- -t)
- __zfs_complete_multiple_options "filesystem volume snapshot all" "$cur"
- ;;
- -s)
- __zfs_complete_multiple_options "local default inherited temporary none" "$cur"
- ;;
- -o)
- __zfs_complete_multiple_options "name property value source received all" "$cur"
- ;;
- *)
- if ! __zfs_complete_switch "H,r,p,d,o,t,s"
- then
- if __zfs_argument_chosen $(__zfs_get_properties)
- then
- COMPREPLY=($(compgen -W "$(__zfs_match_explicit_snapshot) $(__zfs_list_datasets)" -- "$cur"))
- else
- __zfs_complete_multiple_options "$(__zfs_get_properties)" "$cur"
- fi
- fi
- ;;
- esac
- ;;
- inherit)
- if ! __zfs_complete_switch "r"
- then
- __zfs_complete_ordered_arguments "$(__zfs_get_inheritable_properties)" "$(__zfs_match_explicit_snapshot) $(__zfs_list_datasets)" $cur
- fi
- ;;
- list)
- case "${prev}" in
- -d)
- COMPREPLY=($(compgen -W "" -- "$cur"))
- ;;
- -t)
- __zfs_complete_multiple_options "filesystem volume snapshot all" "$cur"
- ;;
- -o)
- __zfs_complete_multiple_options "$(__zfs_get_properties)" "$cur"
- ;;
- -s|-S)
- COMPREPLY=($(compgen -W "$(__zfs_get_properties)" -- "$cur"))
- ;;
- *)
- if ! __zfs_complete_switch "H,r,d,o,t,s,S"
- then
- COMPREPLY=($(compgen -W "$(__zfs_match_explicit_snapshot) $(__zfs_list_datasets)" -- "$cur"))
- fi
- ;;
- esac
- ;;
- promote)
- COMPREPLY=($(compgen -W "$(__zfs_list_filesystems)" -- "$cur"))
- ;;
- rollback)
- if ! __zfs_complete_switch "r,R,f"
- then
- COMPREPLY=($(compgen -W "$(__zfs_match_snapshot)" -- "$cur"))
- fi
- ;;
- send)
- if ! __zfs_complete_switch "d,n,P,p,R,v,i,I"
- then
- COMPREPLY=($(compgen -W "$(__zfs_match_snapshot)" -- "$cur"))
- fi
- ;;
- snapshot)
- case "${prev}" in
- -o)
- COMPREPLY=($(compgen -W "$(__zfs_get_editable_properties)" -- "$cur"))
- ;;
- *)
- if ! __zfs_complete_switch "o,r"
- then
- COMPREPLY=($(compgen -W "$(__zfs_list_datasets | awk '{print $1"@"}')" -- "$cur"))
- fi
- ;;
- esac
- ;;
- set)
- __zfs_complete_ordered_arguments "$(__zfs_get_editable_properties)" "$(__zfs_match_explicit_snapshot) $(__zfs_list_datasets)" $cur
- ;;
- upgrade)
- case "${prev}" in
- -a|-V|-v)
- COMPREPLY=($(compgen -W "" -- "$cur"))
- ;;
- *)
- if ! __zfs_complete_switch "a,V,v,r"
- then
- COMPREPLY=($(compgen -W "$(__zfs_list_filesystems)" -- "$cur"))
- fi
- ;;
- esac
- ;;
- destroy)
- if ! __zfs_complete_switch "d,f,n,p,R,r,v"
- then
- __zfs_complete_multiple_options "$(__zfs_match_multiple_snapshots)" $cur
- fi
- ;;
- *)
- COMPREPLY=($(compgen -W "$(__zfs_match_explicit_snapshot) $(__zfs_list_datasets)" -- "$cur"))
- ;;
- esac
- __ltrim_colon_completions "$cur"
- return 0
-}
-
-__zpool_get_commands()
-{
- $__ZPOOL_CMD 2>&1 | awk '/^\t[a-z]/ {print $1}' | uniq
-}
-
-__zpool_get_properties()
-{
- $__ZPOOL_CMD get 2>&1 | awk '$2 == "YES" || $2 == "NO" {print $1}'; echo all
-}
-
-__zpool_get_editable_properties()
-{
- $__ZPOOL_CMD get 2>&1 | awk '$2 == "YES" {print $1"="}'
-}
-
-__zpool_list_pools()
-{
- $__ZPOOL_CMD list -H -o name
-}
-
-__zpool_complete()
-{
- local cur prev cmd cmds
- COMPREPLY=()
- cur="${COMP_WORDS[COMP_CWORD]}"
- prev="${COMP_WORDS[COMP_CWORD-1]}"
- cmd="${COMP_WORDS[1]}"
-
- if [[ ${prev##*/} == zpool ]]
- then
- cmds=$(__zpool_get_commands)
- COMPREPLY=($(compgen -W "$cmds" -- "$cur"))
- return 0
- fi
-
- case "${cmd}" in
- get)
- __zfs_complete_ordered_arguments "$(__zpool_get_properties)" "$(__zpool_list_pools)" $cur
- return 0
- ;;
- import)
- if [[ $prev == -d ]]
- then
- _filedir -d
- else
- COMPREPLY=($(compgen -W "$(__zpool_list_pools) -d" -- "$cur"))
- fi
- return 0
- ;;
- set)
- __zfs_complete_ordered_arguments "$(__zpool_get_editable_properties)" "$(__zpool_list_pools)" $cur
- return 0
- ;;
- add|attach|clear|create|detach|offline|online|remove|replace)
- local pools="$(__zpool_list_pools)"
- if __zfs_argument_chosen $pools
- then
- _filedir
- else
- COMPREPLY=($(compgen -W "$pools" -- "$cur"))
- fi
- return 0
- ;;
- *)
- COMPREPLY=($(compgen -W "$(__zpool_list_pools)" -- "$cur"))
- return 0
- ;;
- esac
-
-}
-
-complete -F __zfs_complete zfs
-complete -F __zpool_complete zpool
diff --git a/zfs.initcpio.hook b/zfs.initcpio.hook
deleted file mode 100644
index 222a7e18411b..000000000000
--- a/zfs.initcpio.hook
+++ /dev/null
@@ -1,119 +0,0 @@
-#
-# WARNING: This script is parsed by ash in busybox at boot time, not bash!
-# http://linux.die.net/man/1/ash
-# https://wiki.ubuntu.com/DashAsBinSh
-# http://www.jpsdomain.org/public/2008-JP_bash_vs_dash.pdf
-#
-ZPOOL_FORCE=""
-ZPOOL_IMPORT_FLAGS=""
-
-zfs_get_bootfs () {
- for zfs_dataset in $(zpool list -H -o bootfs); do
- case ${zfs_dataset} in
- "" | "-")
- # skip this line/dataset
- ;;
- "no pools available")
- return 1
- ;;
- *)
- ZFS_DATASET=${zfs_dataset}
- return 0
- ;;
- esac
- done
- return 1
-}
-
-zfs_mount_handler () {
- if [ "${ZFS_DATASET}" = "bootfs" ] ; then
- if ! zfs_get_bootfs ; then
- # Lets import everything and try again
- zpool import ${ZPOOL_IMPORT_FLAGS} -N -a ${ZPOOL_FORCE}
- if ! zfs_get_bootfs ; then
- die "ZFS: Cannot find bootfs."
- fi
- fi
- fi
-
- local pool="${ZFS_DATASET%%/*}"
- local rwopt_exp="${rwopt:-ro}"
-
- if ! zpool list -H "${pool}" 2&>1 > /dev/null ; then
- if [ ! "${rwopt_exp}" = "rw" ]; then
- msg "ZFS: Importing pool ${pool} readonly."
- ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -o readonly=on"
- else
- msg "ZFS: Importing pool ${pool}."
- fi
-
- if ! zpool import ${ZPOOL_IMPORT_FLAGS} -N "${pool}" ${ZPOOL_FORCE} ; then
- die "ZFS: Unable to import pool ${pool}."
- fi
- fi
-
- local node="$1"
- local tab_file="${node}/etc/fstab"
- local zfs_datasets="$(zfs list -H -o name -t filesystem -r ${ZFS_DATASET})"
-
- # Mount the root, and any child datasets
- for dataset in ${zfs_datasets}; do
- mountpoint=$(zfs get -H -o value mountpoint "${dataset}")
- case ${mountpoint} in
- "none")
- # skip this line/dataset.
- ;;
- "legacy")
- if [ -f "${tab_file}" ]; then
- if findmnt -snero source -F "${tab_file}" -S "${dataset}" > /dev/null 2>&1; then
- opt=$(findmnt -snero options -F "${tab_file}" -S "${dataset}")
- mnt=$(findmnt -snero target -F "${tab_file}" -S "${dataset}")
- mount -t zfs -o "${opt}" "${dataset}" "${node}${mnt}"
- fi
- fi
- ;;
- *)
- mount -t zfs -o "zfsutil,${rwopt_exp}" "${dataset}" "${node}${mountpoint}"
- ;;
- esac
- done
-}
-
-run_hook() {
- # Force import the pools, useful if the pool has not properly been exported using 'zpool export <pool>'
- [ ! "${zfs_force}" = "" ] && ZPOOL_FORCE="-f"
-
- # Add import directory to import command flags
- [ ! "${zfs_import_dir}" = "" ] && ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -d ${zfs_import_dir}"
-
- # Wait 15 seconds for ZFS devices to show up
- [ "${zfs_wait}" = "" ] && ZFS_WAIT="15" || ZFS_WAIT="${zfs_wait}"
-
- [ "${root}" = "zfs" ] && mount_handler="zfs_mount_handler"
-
- case ${zfs} in
- "")
- # skip this line/dataset
- ;;
- auto|bootfs)
- ZFS_DATASET="bootfs"
- mount_handler="zfs_mount_handler"
- ;;
- *)
- ZFS_DATASET="${zfs}"
- mount_handler="zfs_mount_handler"
- ;;
- esac
-
- # Allow up to n seconds for zfs device to show up
- for i in $(seq 1 ${ZFS_WAIT}); do
- [ -c "/dev/zfs" ] && break
- sleep 1
- done
-}
-
-run_latehook () {
- zpool import -N -a ${ZPOOL_FORCE}
-}
-
-# vim:set ts=4 sw=4 ft=sh et:
diff --git a/zfs.initcpio.install b/zfs.initcpio.install
deleted file mode 100644
index 19364a386a45..000000000000
--- a/zfs.initcpio.install
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/bash
-
-build() {
- map add_module \
- zavl \
- znvpair \
- zunicode \
- zcommon \
- zfs \
- zpios \
- spl \
- splat \
- zlib_deflate
-
- map add_binary \
- arcstat.py \
- dbufstat.py \
- fsck.zfs \
- mount.zfs \
- seq \
- zdb \
- zed \
- zfs \
- zhack \
- zinject \
- zpios \
- zpool \
- zstreamdump \
- ztest \
- splat \
- /lib/udev/vdev_id \
- /lib/udev/zvol_id \
- findmnt
-
- map add_file \
- /lib/udev/rules.d/60-zvol.rules \
- /lib/udev/rules.d/69-vdev.rules \
- /lib/udev/rules.d/90-zfs.rules \
- /lib/libgcc_s.so.1
-
- map add_dir \
- /etc/zfs/zed.d
-
- add_runscript
-
- # allow mount(8) to "autodetect" ZFS
- echo 'zfs' >>"${BUILDROOT}/etc/filesystems"
-
- [[ -f /etc/zfs/zpool.cache ]] && add_file "/etc/zfs/zpool.cache"
- [[ -f /etc/modprobe.d/zfs.conf ]] && add_file "/etc/modprobe.d/zfs.conf"
-}
-
-help() {
- cat<<HELPEOF
-This hook allows you to use ZFS as your root filesystem.
-
-Command Line Setup:
-
- You can append the following arguments to your kernel parameters list. See
- https://wiki.archlinux.org/index.php/Kernel_parameters for more information.
-
- To use ZFS as your boot filesystem:
-
- zfs=bootfs or zfs=auto or root=zfs
-
- To use a pool or dataset:
-
- zfs=<pool/dataset>
-
- To force importing of a ZFS pool:
-
- zfs_force=1
-
- If set to 1, this will use "zpool import -f" when attempting to import
- pools.
-
- To change the seconds of time to wait for ZFS devices to show up at boot:
-
- zfs_wait=30
-
- To search for devices in a directory other than "/dev":
-
- zfs_import_dir=/dev/disk/by-uuid
- or
- zfs_import_dir=/dev/disk/by-partuuid
- or
- zfs_import_dir=/dev/disk/by-path
- etc.
-
- Following initcpio convention, the 'rw' option must be specified to load the
- pool as read/write. Pools are loaded as read only by default.
-
-Examples:
-
- To use bootfs on your pool, use
-
- zfs=bootfs rw
-
- This will setup your root using tank/root zfs pool.
-
- zfs=tank/root rw
-
-If you want to set properties for zfs-on-linux module, you should add them to
-/etc/modprobe.d/zfs.conf and then rebuild initcpio.
-
-HELPEOF
-}
-
-# vim: set ts=4 sw=4 ft=sh et: