summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-07-28 02:47:04 -0700
committerJesus Alvarez2017-07-28 02:47:04 -0700
commit0d418c16a27bdf78e309f1d1210ec01c0b701daa (patch)
tree4fc46092da95fa4da54c21ba031e807bc2ff4f30
parent25fac2c143dca60b896fa6064b6ad385c36f8dfb (diff)
downloadaur-0d418c16a27bdf78e309f1d1210ec01c0b701daa.tar.gz
Semi-automated update for 4.11.9_1-1
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD49
-rw-r--r--zfs.install2
3 files changed, 51 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d3552714163..40af3c4e1304 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,33 @@
# Generated by mksrcinfo v8
-# Mon May 1 14:05:52 UTC 2017
+# Fri Jul 28 09:10:18 UTC 2017
pkgbase = zfs-linux
- pkgdesc = Kernel modules for the Zettabyte File System.
- pkgver = 0.6.5.9_4.10.13_1
+ pkgver = 0.7.0_4.11.9_1
pkgrel = 1
url = http://zfsonlinux.org/
- install = zfs.install
arch = x86_64
- groups = archzfs-linux
license = CDDL
- makedepends = linux-headers=4.10.13-1
+ makedepends = linux-headers=4.11.9-1
+ makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
- depends = zfs-utils-linux
- depends = linux=4.10.13-1
+ depends = zfs-utils-common
+ depends = linux=4.11.9-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz
+ sha256sums = 6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2
+
+pkgname = zfs-linux
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ install = zfs.install
+ groups = archzfs-linux
provides = zfs
conflicts = zfs-linux-git
- conflicts = zfs-linux-lts
replaces = zfs-git
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.9/zfs-0.6.5.9.tar.gz
- sha256sums = b724b57dbddae59246fdc15f88f1224061c712945bb36412a2087e0c7760d77f
-pkgname = zfs-linux
+pkgname = zfs-linux-headers
+ pkgdesc = Kernel headers for the Zettabyte File System.
+ conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-lts-headers
+ conflicts = zfs-linux-lts-git-headers
+ conflicts = zfs-linux-hardened-headers
+ conflicts = zfs-linux-hardened-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 98081bc42418..6408718e5658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,39 +14,50 @@
# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
# archzfs github page.
#
-pkgname="zfs-linux"
-pkgver=0.6.5.9_4.10.13_1
+pkgbase="zfs-linux"
+pkgname=("zfs-linux" "zfs-linux-headers")
+pkgver=0.7.0_4.11.9_1
pkgrel=1
-pkgdesc="Kernel modules for the Zettabyte File System."
-depends=("kmod" "spl-linux" "zfs-utils-linux" "linux=4.10.13-1")
-makedepends=("linux-headers=4.10.13-1")
+makedepends=("linux-headers=4.11.9-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.9/zfs-0.6.5.9.tar.gz")
-sha256sums=("b724b57dbddae59246fdc15f88f1224061c712945bb36412a2087e0c7760d77f")
-groups=("archzfs-linux")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz")
+sha256sums=("6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2")
license=("CDDL")
-install=zfs.install
-provides=("zfs")
-conflicts=('zfs-linux-git' 'zfs-linux-lts')
-replaces=("zfs-git")
+depends=("kmod" "spl-linux" "zfs-utils-common" "linux=4.11.9-1")
build() {
- cd "${srcdir}/zfs-0.6.5.9"
+ cd "${srcdir}/zfs-0.7.0"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.6.5.9 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.10.13-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.10.13-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.0 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.11.9-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.11.9-1-ARCH/build
make
}
-package() {
- cd "${srcdir}/zfs-0.6.5.9"
+package_zfs-linux() {
+ pkgdesc="Kernel modules for the Zettabyte File System."
+ install=zfs.install
+ provides=("zfs")
+ groups=("archzfs-linux")
+ conflicts=('zfs-linux-git')
+ replaces=("zfs-git")
+ cd "${srcdir}/zfs-0.7.0"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_zfs-linux-headers() {
+ pkgdesc="Kernel headers for the Zettabyte File System."
+ conflicts=('zfs-linux-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers')
+ cd "${srcdir}/zfs-0.7.0"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.10.13-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.11.9-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 9ad4d7268b2d..fe3157208e48 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.10.13-1-ARCH
+ depmod -a 4.11.9-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' ]]; then
if [[ $1 == 'remove' ]]; then