summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-05-18 10:09:00 -0700
committerJesus Alvarez2018-05-18 10:09:00 -0700
commit1e73d05b12113750bd77c88e9b179ca4be8f22c4 (patch)
tree3b032b02a508f03d035fb330ebfdf177fcb69012
parentd43be36b0bd1c9f1c533c999cf6951c19aac3651 (diff)
downloadaur-1e73d05b12113750bd77c88e9b179ca4be8f22c4.tar.gz
Semi-automated update for 4.16.9.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1768376f7f88..76a815f17679 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux
- pkgver = 0.7.9.4.16.8.1
+ pkgver = 0.7.9.4.16.9.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.16.8-1
+ makedepends = linux-headers=4.16.9-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.9
- depends = linux=4.16.8-1
+ depends = linux=4.16.9-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz
sha256sums = f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a
diff --git a/PKGBUILD b/PKGBUILD
index b5158b6b1bb4..39a668d956ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.9.4.16.8.1
+pkgver=0.7.9.4.16.9.1
pkgrel=1
-makedepends=("linux-headers=4.16.8-1" "spl-linux-headers")
+makedepends=("linux-headers=4.16.9-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz")
sha256sums=("f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.9" "linux=4.16.8-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.9" "linux=4.16.9-1")
build() {
cd "${srcdir}/zfs-0.7.9"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.16.8-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.16.8-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.16.9-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.16.9-1-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.8-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.9-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 332e55f8eaab..6cea4d23951b 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.16.8-1-ARCH
+ depmod -a 4.16.9-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'