summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-13 16:26:14 -0700
committerJesus Alvarez2017-08-13 16:26:14 -0700
commit268a8e264023fb647e1d882b8e88061ebd6c5e48 (patch)
tree2d006b0fe1a4ab2611e78891280986b5e8b76688
parent8916b322876e1f02eccd16ab68b3d389dddcf33d (diff)
downloadaur-268a8e264023fb647e1d882b8e88061ebd6c5e48.tar.gz
Semi-automated update for 4.12.6.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc6830467d50..62fd77bfc9a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Thu Aug 10 04:28:11 UTC 2017
+# Sun Aug 13 20:46:00 UTC 2017
pkgbase = zfs-linux
- pkgver = 0.7.1_4.12.4_1
+ pkgver = 0.7.1.4.12.6.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.12.4-1
+ makedepends = linux-headers=4.12.6-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common>=0.7.1
- depends = linux=4.12.4-1
+ depends = linux=4.12.6-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.1/zfs-0.7.1.tar.gz
sha256sums = 231b104979ddacfeb1889e1dec175337276e7b3b109d40656089744b5caf3ef6
@@ -31,4 +31,6 @@ pkgname = zfs-linux-headers
conflicts = zfs-linux-lts-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-zen-headers
+ conflicts = zfs-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index b188077f1a31..868853b30604 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,15 +16,15 @@
#
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.1_4.12.4_1
+pkgver=0.7.1.4.12.6.1
pkgrel=1
-makedepends=("linux-headers=4.12.4-1" "spl-linux-headers")
+makedepends=("linux-headers=4.12.6-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.1/zfs-0.7.1.tar.gz")
sha256sums=("231b104979ddacfeb1889e1dec175337276e7b3b109d40656089744b5caf3ef6")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.1" "linux=4.12.4-1")
+depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.1" "linux=4.12.6-1")
build() {
cd "${srcdir}/zfs-0.7.1"
@@ -32,8 +32,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.12.4-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.12.4-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.12.6-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.12.6-1-ARCH/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.1"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.4-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.6-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index da19d480825d..0f423ab48379 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.12.4-1-ARCH
+ depmod -a 4.12.6-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'