summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-11-02 07:28:01 -0700
committerJesus Alvarez2017-11-02 07:28:01 -0700
commit3925972f7a78d20907d69060c6ef15e3b3454252 (patch)
tree0446bf0c2639c6e902b5a4da081f86524dad3b44
parentc1c7676656f7f043f0a0ad41b4fc030fadeffec3 (diff)
downloadaur-3925972f7a78d20907d69060c6ef15e3b3454252.tar.gz
Semi-automated update for 4.13.10.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d004e4c0b3f..dc77d40aa304 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Oct 27 18:28:53 UTC 2017
+# Thu Nov 2 11:33:05 UTC 2017
pkgbase = zfs-linux
- pkgver = 0.7.3.4.13.9.1
+ pkgver = 0.7.3.4.13.10.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.13.9-1
+ makedepends = linux-headers=4.13.10-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common>=0.7.3
- depends = linux=4.13.9-1
+ depends = linux=4.13.10-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.3/zfs-0.7.3.tar.gz
sha256sums = cb8fc606835d3f91471e49aca31a6a0a71733b1cbe74fa510e0fe0efa670fe51
diff --git a/PKGBUILD b/PKGBUILD
index 5d4966fd8896..85cde69868da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.3.4.13.9.1
+pkgver=0.7.3.4.13.10.1
pkgrel=1
-makedepends=("linux-headers=4.13.9-1" "spl-linux-headers")
+makedepends=("linux-headers=4.13.10-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.3/zfs-0.7.3.tar.gz")
sha256sums=("cb8fc606835d3f91471e49aca31a6a0a71733b1cbe74fa510e0fe0efa670fe51")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.3" "linux=4.13.9-1")
+depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.3" "linux=4.13.10-1")
build() {
cd "${srcdir}/zfs-0.7.3"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.13.9-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.13.9-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.13.10-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.13.10-1-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.9-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.10-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index ce0c6f47e9f0..3583905ba183 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.13.9-1-ARCH
+ depmod -a 4.13.10-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'