summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-06 21:43:42 -0800
committerJesus Alvarez2018-03-06 21:43:42 -0800
commit4918fe3bd75ff6acbaf1ba1e77a6f2579fa39533 (patch)
tree0d6baec8b388f68a9aff7512145869621d41325f
parentc7b00e50aef0175d2fd44d3a9eed79846b166ec8 (diff)
downloadaur-4918fe3bd75ff6acbaf1ba1e77a6f2579fa39533.tar.gz
Semi-automated update for 4.15.7.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 941b4173e5fc..b7f06b9286a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux
- pkgver = 0.7.6.4.15.6.1
+ pkgver = 0.7.6.4.15.7.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.15.6-1
+ makedepends = linux-headers=4.15.7-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.6
- depends = linux=4.15.6-1
+ depends = linux=4.15.7-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz
sha256sums = 1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d
@@ -30,6 +30,8 @@ pkgname = zfs-linux-headers
conflicts = zfs-linux-lts-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-threadripper-headers
+ conflicts = zfs-linux-threadripper-git-headers
conflicts = zfs-linux-vfio-headers
conflicts = zfs-linux-vfio-git-headers
conflicts = zfs-linux-zen-headers
diff --git a/PKGBUILD b/PKGBUILD
index 98f921b5065d..5fee10b1c550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.6.4.15.6.1
+pkgver=0.7.6.4.15.7.1
pkgrel=1
-makedepends=("linux-headers=4.15.6-1" "spl-linux-headers")
+makedepends=("linux-headers=4.15.7-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.6" "linux=4.15.6-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.6" "linux=4.15.7-1")
build() {
cd "${srcdir}/zfs-0.7.6"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.15.6-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.15.6-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.15.7-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.15.7-1-ARCH/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.6-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.7-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 7752d7dc6d3f..07242204ff63 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.15.6-1-ARCH
+ depmod -a 4.15.7-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'