summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchzfs Buildbot2018-08-26 19:02:55 +0000
committerArchzfs Buildbot2018-08-26 19:02:55 +0000
commit4a8b343bc931f2bbcaa2da41d3a224c1e78edc3d (patch)
tree88b58daaaed676cd4715c197203e994cca691480
parentb1de99be415ae6df7f3a0f540e56cf6f987adb48 (diff)
downloadaur-4a8b343bc931f2bbcaa2da41d3a224c1e78edc3d.tar.gz
Semi-automated update for kernel 4.18.5.arch1-1 + zfs 0.7.9
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa2ea09fc7a7..8a0d445caad6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux
- pkgver = 0.7.9.4.18.4.arch1.1
+ pkgver = 0.7.9.4.18.5.arch1.1
pkgrel = 2
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.18.4.arch1-1
+ makedepends = linux-headers=4.18.5.arch1-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.9
- depends = linux=4.18.4.arch1-1
+ depends = linux=4.18.5.arch1-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz
source = upstream-ac09630-Fix-zpl_mount-deadlock.patch
source = upstream-9f64c1e-Linux-4.18-compat-inode-timespec_timespec64.patch
diff --git a/PKGBUILD b/PKGBUILD
index 17e5de2d3ae4..7eb0394f3db0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,9 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.9.4.18.4.arch1.1
+pkgver=0.7.9.4.18.5.arch1.1
pkgrel=2
-makedepends=("linux-headers=4.18.4.arch1-1" "spl-linux-headers")
+makedepends=("linux-headers=4.18.5.arch1-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz"
@@ -33,7 +33,7 @@ sha256sums=("f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a"
"03ed45af40850c3a51a6fd14f36c1adc06501c688a67afb13db4fded6ec9db1d"
"afbde4a2507dff989404665dbbdfe18eecf5aba716a6513902affa0e4cb033fe")
license=("CDDL")
-depends=("kmod" 'spl-linux' "zfs-utils-common=0.7.9" "linux=4.18.4.arch1-1")
+depends=("kmod" 'spl-linux' "zfs-utils-common=0.7.9" "linux=4.18.5.arch1-1")
prepare() {
cd "${srcdir}/zfs-0.7.9"
patch -Np1 -i ${srcdir}/upstream-ac09630-Fix-zpl_mount-deadlock.patch
@@ -47,8 +47,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.18.4-arch1-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.18.4-arch1-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.18.5-arch1-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.18.5-arch1-1-ARCH/build
make
}
@@ -74,5 +74,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.18.4-arch1-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.18.5-arch1-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 3914a25bbdd0..0b653ab47b2d 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.18.4-arch1-1-ARCH
+ depmod -a 4.18.5-arch1-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'