summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-13 14:15:46 -0800
committerJesus Alvarez2017-12-13 14:15:46 -0800
commit6129aee0a7f57f9b08fcb716d1491b8618a38474 (patch)
tree27f54fd19d9c8e08b000442b2625bcb0d07933db
parenta7a3d0d854c9b763db942cf2efdf8dde89c78d5b (diff)
downloadaur-6129aee0a7f57f9b08fcb716d1491b8618a38474.tar.gz
Semi-automated update for 4.14.5.1-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--zfs.install2
3 files changed, 25 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68eaa32cde88..9a0b48367559 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Dec 3 23:13:19 UTC 2017
+# Wed Dec 13 20:17:24 UTC 2017
pkgbase = zfs-linux
- pkgver = 0.7.3.4.14.3.1
- pkgrel = 4
+ pkgver = 0.7.4.4.14.5.1
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.14.3-1
+ makedepends = linux-headers=4.14.5-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
- depends = zfs-utils-common=0.7.3
- depends = linux=4.14.3-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.3/zfs-0.7.3.tar.gz
- sha256sums = cb8fc606835d3f91471e49aca31a6a0a71733b1cbe74fa510e0fe0efa670fe51
+ depends = zfs-utils-common=0.7.4
+ depends = linux=4.14.5-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/zfs-0.7.4.tar.gz
+ sha256sums = SKIP
pkgname = zfs-linux
pkgdesc = Kernel modules for the Zettabyte File System.
@@ -31,6 +31,8 @@ pkgname = zfs-linux-headers
conflicts = zfs-linux-lts-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-vfio-headers
+ conflicts = zfs-linux-vfio-git-headers
conflicts = zfs-linux-zen-headers
conflicts = zfs-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index cf46059ba8b9..583515d48991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,24 +17,24 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.3.4.14.3.1
-pkgrel=4
-makedepends=("linux-headers=4.14.3-1" "spl-linux-headers")
+pkgver=0.7.4.4.14.5.1
+pkgrel=1
+makedepends=("linux-headers=4.14.5-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.3/zfs-0.7.3.tar.gz")
-sha256sums=("cb8fc606835d3f91471e49aca31a6a0a71733b1cbe74fa510e0fe0efa670fe51")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/zfs-0.7.4.tar.gz")
+sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.3" "linux=4.14.3-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.4" "linux=4.14.5-1")
build() {
- cd "${srcdir}/zfs-0.7.3"
+ cd "${srcdir}/zfs-0.7.4"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.3-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.14.3-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.4 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.5-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.14.5-1-ARCH/build
make
}
@@ -45,7 +45,7 @@ package_zfs-linux() {
groups=("archzfs-linux")
conflicts=('zfs-linux-git')
replaces=("zfs-git")
- cd "${srcdir}/zfs-0.7.3"
+ cd "${srcdir}/zfs-0.7.4"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -55,10 +55,10 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.3"
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ cd "${srcdir}/zfs-0.7.4"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.3-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.5-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index a904aa72eddd..a06f7a46a71b 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.3-1-ARCH
+ depmod -a 4.14.5-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'