summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-06-13 22:19:09 -0700
committerJesus Alvarez2018-06-13 22:19:09 -0700
commit6ce3b9bd57e4d8f617f45b3ae63a67567b51f93e (patch)
tree423e71037504da6028dc1598bf78780b923028ba
parentb06349f0f290e086698f6fd01d5938b178b6b004 (diff)
downloadaur-6ce3b9bd57e4d8f617f45b3ae63a67567b51f93e.tar.gz
Semi-automated update for 4.16.13.2-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64ebfcdb7f0b..1fa9426a5fad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux
- pkgver = 0.7.9.4.16.13.1
+ pkgver = 0.7.9.4.16.13.2
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.16.13-1
+ makedepends = linux-headers=4.16.13-2
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.9
- depends = linux=4.16.13-1
+ depends = linux=4.16.13-2
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz
sha256sums = f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a
diff --git a/PKGBUILD b/PKGBUILD
index 16f8c16e8638..514a71408436 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.9.4.16.13.1
+pkgver=0.7.9.4.16.13.2
pkgrel=1
-makedepends=("linux-headers=4.16.13-1" "spl-linux-headers")
+makedepends=("linux-headers=4.16.13-2" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz")
sha256sums=("f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a")
license=("CDDL")
-depends=("kmod" 'spl-linux' "zfs-utils-common=0.7.9" "linux=4.16.13-1")
+depends=("kmod" 'spl-linux' "zfs-utils-common=0.7.9" "linux=4.16.13-2")
build() {
cd "${srcdir}/zfs-0.7.9"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.16.13-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.16.13-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.16.13-2-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.16.13-2-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.13-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.13-2-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 13ab6df65581..74cb3a95bcdf 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.16.13-1-ARCH
+ depmod -a 4.16.13-2-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'