summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-04-26 11:33:15 -0700
committerJesus Alvarez2018-04-26 11:33:15 -0700
commit858e7ad231992a8e4aa95be81552d023a6b03770 (patch)
tree6cd44025672385d5e3f6125f62813e19c3aee85a
parent7835e5a3afec96a37ad5c50f5e2a3aa60a4b1565 (diff)
downloadaur-858e7ad231992a8e4aa95be81552d023a6b03770.tar.gz
Semi-automated update for 4.16.4.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5096d3a817a2..626449aed87f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux
- pkgver = 0.7.8.4.16.3.1
+ pkgver = 0.7.8.4.16.4.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.16.3-1
+ makedepends = linux-headers=4.16.4-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.8
- depends = linux=4.16.3-1
+ depends = linux=4.16.4-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.8/zfs-0.7.8.tar.gz
sha256sums = 70ba0edd72914d4bfc9a9426cf26725e955a9509acbddb6902efb9eebb35f150
diff --git a/PKGBUILD b/PKGBUILD
index de8263aa6c5d..3935dd1c5103 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.8.4.16.3.1
+pkgver=0.7.8.4.16.4.1
pkgrel=1
-makedepends=("linux-headers=4.16.3-1" "spl-linux-headers")
+makedepends=("linux-headers=4.16.4-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.8/zfs-0.7.8.tar.gz")
sha256sums=("70ba0edd72914d4bfc9a9426cf26725e955a9509acbddb6902efb9eebb35f150")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.8" "linux=4.16.3-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.8" "linux=4.16.4-1")
build() {
cd "${srcdir}/zfs-0.7.8"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.8 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.16.3-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.16.3-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.16.4-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.16.4-1-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.3-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.4-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index e3fa32dacaf8..99143545f5df 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.16.3-1-ARCH
+ depmod -a 4.16.4-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'