summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-11-13 15:02:00 -0800
committerJesus Alvarez2017-11-13 15:02:00 -0800
commit9fba98e7c49d222a3dd589e19b55167f781a26cb (patch)
tree2949d4d3f231b67f7d000c7f80cb4a0ae26714c2
parent5ae17ec5b8678af644596e9636f17880178d7b66 (diff)
downloadaur-9fba98e7c49d222a3dd589e19b55167f781a26cb.tar.gz
Semi-automated update for 4.13.12.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82ca914c4412..c2918a37603d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Mon Nov 6 13:04:59 UTC 2017
+# Mon Nov 13 22:43:10 UTC 2017
pkgbase = zfs-linux
- pkgver = 0.7.3.4.13.11.1
+ pkgver = 0.7.3.4.13.12.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.13.11-1
+ makedepends = linux-headers=4.13.12-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common>=0.7.3
- depends = linux=4.13.11-1
+ depends = linux=4.13.12-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.3/zfs-0.7.3.tar.gz
sha256sums = cb8fc606835d3f91471e49aca31a6a0a71733b1cbe74fa510e0fe0efa670fe51
diff --git a/PKGBUILD b/PKGBUILD
index 27ee9948d898..a0ced3006071 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.3.4.13.11.1
+pkgver=0.7.3.4.13.12.1
pkgrel=1
-makedepends=("linux-headers=4.13.11-1" "spl-linux-headers")
+makedepends=("linux-headers=4.13.12-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.3/zfs-0.7.3.tar.gz")
sha256sums=("cb8fc606835d3f91471e49aca31a6a0a71733b1cbe74fa510e0fe0efa670fe51")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.3" "linux=4.13.11-1")
+depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.3" "linux=4.13.12-1")
build() {
cd "${srcdir}/zfs-0.7.3"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.13.11-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.13.11-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.13.12-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.13.12-1-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.11-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.12-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index ed49b44de0db..3b643b0debdb 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.13.11-1-ARCH
+ depmod -a 4.13.12-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'