summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-26 09:54:31 -0800
committerJesus Alvarez2017-12-26 09:54:31 -0800
commite15810ecb6d8c227ca94e5cd01f291c97fc60206 (patch)
treedc02eaf46b9d93892e1476bc9eb0ade7b16fff39
parent5c413e676adc1ef416c5679e1e1feeff2567fa48 (diff)
downloadaur-e15810ecb6d8c227ca94e5cd01f291c97fc60206.tar.gz
Semi-automated update for 4.14.8.1-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be7134aa9b7f..37b5a5e80c2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Dec 22 01:15:44 UTC 2017
+# Mon Dec 25 19:47:51 UTC 2017
pkgbase = zfs-linux
- pkgver = 0.7.5.4.14.7.1
+ pkgver = 0.7.5.4.14.8.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.14.7-1
+ makedepends = linux-headers=4.14.8-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.5
- depends = linux=4.14.7-1
+ depends = linux=4.14.8-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz
sha256sums = SKIP
@@ -26,6 +26,7 @@ pkgname = zfs-linux
pkgname = zfs-linux-headers
pkgdesc = Kernel headers for the Zettabyte File System.
conflicts = zfs-archiso-linux-headers
+ conflicts = zfs-archiso-linux-git-headers
conflicts = zfs-linux-hardened-headers
conflicts = zfs-linux-hardened-git-headers
conflicts = zfs-linux-lts-headers
diff --git a/PKGBUILD b/PKGBUILD
index ae91e7a74a85..c99fd7074be8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.5.4.14.7.1
+pkgver=0.7.5.4.14.8.1
pkgrel=1
-makedepends=("linux-headers=4.14.7-1" "spl-linux-headers")
+makedepends=("linux-headers=4.14.8-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.5" "linux=4.14.7-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.5" "linux=4.14.8-1")
build() {
cd "${srcdir}/zfs-0.7.5"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.7-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.14.7-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.14.8-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.14.8-1-ARCH/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.5"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.7-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.8-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 7bd617544c3d..4dbe2d909479 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.7-1-ARCH
+ depmod -a 4.14.8-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'