summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-01-14 23:25:44 -0800
committerJesus Alvarez2018-01-14 23:25:44 -0800
commitfc821c9417596b3cda803cf08e54a2dc684fcd74 (patch)
treeda12bd3bc784da8cf3f877332f4ab63d401063c4
parentd80a3d467109c3e3b900f68a9aa8dd4fc1eb97ae (diff)
downloadaur-fc821c9417596b3cda803cf08e54a2dc684fcd74.tar.gz
Semi-automated update for 4.14.13.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7499ef22420b..99373eba3c5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Sun Jan 7 19:59:25 UTC 2018
+# Sun Jan 14 20:31:17 UTC 2018
pkgbase = zfs-linux
- pkgver = 0.7.5.4.14.12.1
+ pkgver = 0.7.5.4.14.13.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.14.12-1
+ makedepends = linux-headers=4.14.13-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.5
- depends = linux=4.14.12-1
+ depends = linux=4.14.13-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7f1698380aa8..b92463513bcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.5.4.14.12.1
+pkgver=0.7.5.4.14.13.1
pkgrel=1
-makedepends=("linux-headers=4.14.12-1" "spl-linux-headers")
+makedepends=("linux-headers=4.14.13-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.5" "linux=4.14.12-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.5" "linux=4.14.13-1")
build() {
cd "${srcdir}/zfs-0.7.5"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.12-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.14.12-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.14.13-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.14.13-1-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.12-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.13-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index e0c7f4d1b0ca..63b7534b7f0e 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.12-1-ARCH
+ depmod -a 4.14.13-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'