summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-11-13 15:02:27 -0800
committerJesus Alvarez2017-11-13 15:02:27 -0800
commit5b7502489c096faf4a9cadd82c675060b0d6806b (patch)
treed258e1eab07187aaa48741da8e8eb2a267258214
parentf276d97edb3ef00de41fc7fe52d386192db52b52 (diff)
downloadaur-5b7502489c096faf4a9cadd82c675060b0d6806b.tar.gz
Semi-automated update for 4.13.12.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61dacdb7fc54..35b189031705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Mon Nov 6 13:09:12 UTC 2017
+# Mon Nov 13 22:48:30 UTC 2017
pkgbase = zfs-linux-git
- pkgver = 0.7.0.r167.g23ea00a1f.4.13.11.1
+ pkgver = 0.7.0.r186.g99834d195.4.13.12.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.13.11-1
+ makedepends = linux-headers=4.13.12-1
makedepends = git
makedepends = spl-linux-git-headers
depends = kmod
depends = spl-linux-git
- depends = zfs-utils-common-git>=0.7.0.r167.g23ea00a1f
- depends = linux=4.13.11-1
+ depends = zfs-utils-common-git>=0.7.0.r186.g99834d195
+ depends = linux=4.13.12-1
source = git+https://github.com/zfsonlinux/zfs.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 657360bb5788..d443e4da6321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,19 +17,19 @@
pkgbase="zfs-linux-git"
pkgname=("zfs-linux-git" "zfs-linux-git-headers")
-pkgver=0.7.0.r167.g23ea00a1f.4.13.11.1
+pkgver=0.7.0.r186.g99834d195.4.13.12.1
pkgrel=1
-makedepends=("linux-headers=4.13.11-1" "git" "spl-linux-git-headers")
+makedepends=("linux-headers=4.13.12-1" "git" "spl-linux-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-git" "zfs-utils-common-git>=0.7.0.r167.g23ea00a1f" "linux=4.13.11-1")
+depends=("kmod" "spl-linux-git" "zfs-utils-common-git>=0.7.0.r186.g99834d195" "linux=4.13.12-1")
pkgver() {
cd "${srcdir}/zfs"
- echo $(git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g').4.13.11.1
+ echo $(git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g').4.13.12.1
}
build() {
@@ -38,8 +38,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.13.11-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.13.11-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.13.12-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.13.12-1-ARCH/build
make
}
@@ -65,5 +65,5 @@ package_zfs-linux-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.11-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.13.12-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index ed49b44de0db..3b643b0debdb 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.13.11-1-ARCH
+ depmod -a 4.13.12-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'