summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-13 14:16:17 -0800
committerJesus Alvarez2017-12-13 14:16:17 -0800
commit726b9dc39568bc7fa7f7a4d601cf3c028969facf (patch)
treeae78746851f7aed15900e47566e2e3af318400ba
parent19d44c1b74f022d5464f7eeb5305089590055866 (diff)
downloadaur-726b9dc39568bc7fa7f7a4d601cf3c028969facf.tar.gz
Semi-automated update for 4.14.5.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--zfs.install2
3 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22f4b5be7a75..724a6353701a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Dec 3 23:18:04 UTC 2017
+# Wed Dec 13 20:22:27 UTC 2017
pkgbase = zfs-linux-git
- pkgver = 0.7.0.r200.gd4677269f.4.14.3.1
- pkgrel = 4
+ pkgver = 2017.12.08.r3208.4e9b15696.4.14.5.1
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.14.3-1
+ makedepends = linux-headers=4.14.5-1
makedepends = git
makedepends = spl-linux-git-headers
depends = kmod
depends = spl-linux-git
- depends = zfs-utils-common-git>=0.7.0.r200.gd4677269f
- depends = linux=4.14.3-1
- source = git+https://github.com/zfsonlinux/zfs.git
+ depends = zfs-utils-common-git=2017.12.08.r3208.4e9b15696
+ depends = linux=4.14.5-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=4e9b156960562373e005798575a3fbc6d66e32ff
sha256sums = SKIP
pkgname = zfs-linux-git
@@ -32,6 +32,8 @@ pkgname = zfs-linux-git-headers
conflicts = zfs-linux-lts-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-headers
+ conflicts = zfs-linux-vfio-headers
+ conflicts = zfs-linux-vfio-git-headers
conflicts = zfs-linux-zen-headers
conflicts = zfs-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 91de2457212e..5c9d8e851519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,29 +17,24 @@
pkgbase="zfs-linux-git"
pkgname=("zfs-linux-git" "zfs-linux-git-headers")
-pkgver=0.7.0.r200.gd4677269f.4.14.3.1
-pkgrel=4
-makedepends=("linux-headers=4.14.3-1" "git" "spl-linux-git-headers")
+pkgver=2017.12.08.r3208.4e9b15696.4.14.5.1
+pkgrel=1
+makedepends=("linux-headers=4.14.5-1" "git" "spl-linux-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=4e9b156960562373e005798575a3fbc6d66e32ff")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-git" "zfs-utils-common-git>=0.7.0.r200.gd4677269f" "linux=4.14.3-1")
-
-pkgver() {
- cd "${srcdir}/zfs"
- echo $(git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g').4.14.3.1
-}
+depends=("kmod" "spl-linux-git" "zfs-utils-common-git=2017.12.08.r3208.4e9b15696" "linux=4.14.5-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.3-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.14.3-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.4 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.5-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.14.5-1-ARCH/build
make
}
@@ -60,10 +55,10 @@ package_zfs-linux-git() {
package_zfs-linux-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.3-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.5-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index a904aa72eddd..a06f7a46a71b 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.3-1-ARCH
+ depmod -a 4.14.5-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'