summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-05-11 15:49:44 -0700
committerJesus Alvarez2018-05-11 15:49:44 -0700
commitaadd3dc6370f08490b9a845873bac58714f1b862 (patch)
treecdfebf68a748cab80d293dd545da9a3b722f7597
parentdfce99d502d5a1055e225e96b8e34183e5b6b01e (diff)
downloadaur-aadd3dc6370f08490b9a845873bac58714f1b862.tar.gz
Semi-automated update for 4.16.8.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--zfs.install2
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c8ebc81c300..7dc24871c918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = zfs-linux-git
- pkgver = 2018.05.06.r3465.ga82a4a15b.4.16.7.1
+ pkgver = 2018.05.11.r3478.gbc5f51c5d.4.16.8.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.16.7-1
+ makedepends = linux-headers=4.16.8-1
makedepends = git
makedepends = spl-linux-git-headers
depends = kmod
depends = spl-linux-git
- depends = zfs-utils-common-git=2018.05.06.r3465.ga82a4a15b
- depends = linux=4.16.7-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=a82a4a15be9559b20ec8e8df1430fc4c901d0b69
+ depends = zfs-utils-common-git=2018.05.11.r3478.gbc5f51c5d
+ depends = linux=4.16.8-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=bc5f51c5de21fd8b7cf3110801a6b1db1e4c3d0a
sha256sums = SKIP
pkgname = zfs-linux-git
diff --git a/PKGBUILD b/PKGBUILD
index 19e0704df8c9..c23834ca2192 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,24 +17,24 @@
pkgbase="zfs-linux-git"
pkgname=("zfs-linux-git" "zfs-linux-git-headers")
-pkgver=2018.05.06.r3465.ga82a4a15b.4.16.7.1
+pkgver=2018.05.11.r3478.gbc5f51c5d.4.16.8.1
pkgrel=1
-makedepends=("linux-headers=4.16.7-1" "git" "spl-linux-git-headers")
+makedepends=("linux-headers=4.16.8-1" "git" "spl-linux-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=a82a4a15be9559b20ec8e8df1430fc4c901d0b69")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=bc5f51c5de21fd8b7cf3110801a6b1db1e4c3d0a")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-git" "zfs-utils-common-git=2018.05.06.r3465.ga82a4a15b" "linux=4.16.7-1")
+depends=("kmod" "spl-linux-git" "zfs-utils-common-git=2018.05.11.r3478.gbc5f51c5d" "linux=4.16.8-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.8 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.16.7-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.16.7-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.16.8-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.16.8-1-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.7-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.8-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 13704e8eb810..332e55f8eaab 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.16.7-1-ARCH
+ depmod -a 4.16.8-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'