summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-16 20:52:01 -0700
committerJesus Alvarez2018-03-16 20:52:01 -0700
commitb18e532a2b54e7d0234aba1c58466868750f0f90 (patch)
tree0453a3e8615a448d1cd64e8187b3469932be6cee
parentcddeff106f370fe893de2937ad0f5b1722d24c61 (diff)
downloadaur-b18e532a2b54e7d0234aba1c58466868750f0f90.tar.gz
Semi-automated update for 4.15.9.a.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf01888e0b59..b5a2694907ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux-hardened
- pkgver = 0.7.6_4.15.8.a.1
+ pkgver = 0.7.6_4.15.9.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.15.8.a-1
+ makedepends = linux-hardened-headers=4.15.9.a-1
makedepends = spl-linux-hardened-headers
depends = kmod
depends = spl-linux-hardened
depends = zfs-utils-common=0.7.6
- depends = linux-hardened=4.15.8.a-1
+ depends = linux-hardened=4.15.9.a-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz
sha256sums = 1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d
@@ -29,10 +29,6 @@ pkgname = zfs-linux-hardened-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-headers
conflicts = zfs-linux-git-headers
- conflicts = zfs-linux-threadripper-headers
- conflicts = zfs-linux-threadripper-git-headers
- conflicts = zfs-linux-threadripper-vfio-headers
- conflicts = zfs-linux-threadripper-vfio-git-headers
conflicts = zfs-linux-vfio-headers
conflicts = zfs-linux-vfio-git-headers
conflicts = zfs-linux-zen-headers
diff --git a/PKGBUILD b/PKGBUILD
index 3e8ce8e1cf31..d9cb2aef9a42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,15 @@
pkgbase="zfs-linux-hardened"
pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
-pkgver=0.7.6_4.15.8.a.1
+pkgver=0.7.6_4.15.9.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.15.8.a-1" "spl-linux-hardened-headers")
+makedepends=("linux-hardened-headers=4.15.9.a-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.6" "linux-hardened=4.15.8.a-1")
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.6" "linux-hardened=4.15.9.a-1")
build() {
cd "${srcdir}/zfs-0.7.6"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.15.8-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.8-1-hardened/build
+ --with-linux=/usr/lib/modules/4.15.9-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.9-1-hardened/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux-hardened() {
package_zfs-linux-hardened-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-threadripper-vfio-headers' 'zfs-linux-threadripper-vfio-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.8-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.9-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 5da816d4c400..5077462fd044 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.15.8-1-hardened
+ depmod -a 4.15.9-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'