summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-13 16:27:29 -0700
committerJesus Alvarez2017-08-13 16:27:29 -0700
commit08c636665c81767a294acf36563fa82a8cc416d8 (patch)
tree0d0ab848e380c2cc3150257adad59b46f762eb7e
parentda7c57e22deac672572b5d1fab87f27f967eb276 (diff)
downloadaur-08c636665c81767a294acf36563fa82a8cc416d8.tar.gz
Semi-automated update for 4.12.7.a.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29436d5e6e3f..23a457562b03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Thu Aug 10 04:55:28 UTC 2017
+# Sun Aug 13 23:08:22 UTC 2017
pkgbase = zfs-linux-hardened-git
- pkgver = 0.7.0_r19_g46364cb2f_4.12.5.a_1
+ pkgver = 0.7.0.r25.g376994828.4.12.7.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.12.5.a-1
+ makedepends = linux-hardened-headers=4.12.7.a-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
- depends = zfs-utils-common-git>=0.7.0_r19_g46364cb2f
- depends = linux-hardened=4.12.5.a-1
+ depends = zfs-utils-common-git>=0.7.0.r25.g376994828
+ depends = linux-hardened=4.12.7.a-1
source = git+https://github.com/zfsonlinux/zfs.git
sha256sums = SKIP
@@ -31,4 +31,6 @@ pkgname = zfs-linux-hardened-git-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-headers
conflicts = zfs-linux-git-headers
+ conflicts = zfs-linux-zen-headers
+ conflicts = zfs-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index c1c6f82f801d..dda29cb09dd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
#
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=0.7.0_r19_g46364cb2f_4.12.5.a_1
+pkgver=0.7.0.r25.g376994828.4.12.7.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.12.5.a-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.12.7.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0_r19_g46364cb2f" "linux-hardened=4.12.5.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0.r25.g376994828" "linux-hardened=4.12.7.a-1")
build() {
cd "${srcdir}/zfs"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.12.5-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.12.5-1-hardened/build
+ --with-linux=/usr/lib/modules/4.12.7-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.7-1-hardened/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux-hardened-git() {
package_zfs-linux-hardened-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.5-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.7-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 4c3f092e0260..9f41dc63c96d 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.12.5-1-hardened
+ depmod -a 4.12.7-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'