summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-20 15:29:26 -0700
committerJesus Alvarez2018-03-20 15:29:26 -0700
commit2cc49b57344a35782d25fc6ce1371bdf85ddcd5a (patch)
treedcda274fc602650ae548239033d8124d229b17a2
parentd8c41f9d7c17b0382a126bcebf83fd3797063a49 (diff)
downloadaur-2cc49b57344a35782d25fc6ce1371bdf85ddcd5a.tar.gz
Semi-automated update for 4.15.11.a.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f69fcf43b3c4..ecc132613163 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = zfs-linux-hardened-git
- pkgver = 2018.03.20.r3377.089fbf313.4.15.10.a.1
+ pkgver = 2018.03.20.r3377.089fbf313.4.15.11.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.15.10.a-1
+ makedepends = linux-hardened-headers=4.15.11.a-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
depends = zfs-utils-common-git=2018.03.20.r3377.089fbf313
- depends = linux-hardened=4.15.10.a-1
+ depends = linux-hardened=4.15.11.a-1
source = git+https://github.com/zfsonlinux/zfs.git#commit=089fbf313c59b178c11614b2aed78efc46d60499
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 146c206cb6eb..cf2bb9b0831a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,15 @@
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=2018.03.20.r3377.089fbf313.4.15.10.a.1
+pkgver=2018.03.20.r3377.089fbf313.4.15.11.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.15.10.a-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.15.11.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git#commit=089fbf313c59b178c11614b2aed78efc46d60499")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2018.03.20.r3377.089fbf313" "linux-hardened=4.15.10.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2018.03.20.r3377.089fbf313" "linux-hardened=4.15.11.a-1")
build() {
cd "${srcdir}/zfs"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.7 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.15.10-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.10-1-hardened/build
+ --with-linux=/usr/lib/modules/4.15.11-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.11-1-hardened/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.10-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.11-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index a25e291041ce..6a7b8fa7a494 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.15.10-1-hardened
+ depmod -a 4.15.11-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'