summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-01-01 15:35:06 -0800
committerJesus Alvarez2018-01-01 15:35:06 -0800
commit4c5fdf6f7690ed5970739ebf682c9b93020dba6f (patch)
tree8f24f11ee7c440d31ff44650840f35dab75bce06
parent0d6d24f83c060b858092809911aa7cddf46a7f45 (diff)
downloadaur-4c5fdf6f7690ed5970739ebf682c9b93020dba6f.tar.gz
Semi-automated update for 4.14.10.a.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 829bdfab4f4b..1c5e71369bac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Thu Dec 28 18:43:24 UTC 2017
+# Mon Jan 1 22:26:10 UTC 2018
pkgbase = zfs-linux-hardened-git
- pkgver = 2017.12.28.r3224.390d679ac.4.14.9.a.1
+ pkgver = 2017.12.28.r3224.390d679ac.4.14.10.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.14.9.a-1
+ makedepends = linux-hardened-headers=4.14.10.a-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
depends = zfs-utils-common-git=2017.12.28.r3224.390d679ac
- depends = linux-hardened=4.14.9.a-1
+ depends = linux-hardened=4.14.10.a-1
source = git+https://github.com/zfsonlinux/zfs.git#commit=390d679acdfa6a2498280a4dcd33b7600ace27ce
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ceec59307216..ee29ec712644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,15 @@
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=2017.12.28.r3224.390d679ac.4.14.9.a.1
+pkgver=2017.12.28.r3224.390d679ac.4.14.10.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.9.a-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.14.10.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git#commit=390d679acdfa6a2498280a4dcd33b7600ace27ce")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2017.12.28.r3224.390d679ac" "linux-hardened=4.14.9.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2017.12.28.r3224.390d679ac" "linux-hardened=4.14.10.a-1")
build() {
cd "${srcdir}/zfs"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.9-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.9-1-hardened/build
+ --with-linux=/usr/lib/modules/4.14.10-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.10-1-hardened/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.9-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.10-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index b7b8eb94b465..1347b3a18ae5 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.9-1-hardened
+ depmod -a 4.14.10-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'