summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-02-06 11:03:32 -0800
committerJesus Alvarez2018-02-06 11:03:32 -0800
commit85835bd803d56a3fdd4e6b40ad2e14a7c741066f (patch)
treec4f1e4af1dc09290cce7f9c036b986dd9f47e704
parent9a8e19dd0c9e83bd5b8922af6229ac1f10a73444 (diff)
downloadaur-85835bd803d56a3fdd4e6b40ad2e14a7c741066f.tar.gz
Semi-automated update for 4.14.17.a.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--zfs.install2
3 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c41568e20cbe..a6d2d6c20c65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed Jan 24 18:34:54 UTC 2018
pkgbase = zfs-linux-hardened-git
- pkgver = 2018.01.19.r3252.6bc4a2376.4.14.14.a.1
+ pkgver = 2018.02.05.r3278.3d25488af.4.14.17.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.14.14.a-1
+ makedepends = linux-hardened-headers=4.14.17.a-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
- depends = zfs-utils-common-git=2018.01.19.r3252.6bc4a2376
- depends = linux-hardened=4.14.14.a-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=6bc4a2376c694f813d2ee78af3d749aa2684f391
+ depends = zfs-utils-common-git=2018.02.05.r3278.3d25488af
+ depends = linux-hardened=4.14.17.a-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=3d25488afbc2eeaa92b12f7f8b6d686e7ef342eb
sha256sums = SKIP
pkgname = zfs-linux-hardened-git
diff --git a/PKGBUILD b/PKGBUILD
index d5cf7834e055..ca0f992695bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,24 +18,24 @@
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=2018.01.19.r3252.6bc4a2376.4.14.14.a.1
+pkgver=2018.02.05.r3278.3d25488af.4.14.17.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.14.a-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.14.17.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=6bc4a2376c694f813d2ee78af3d749aa2684f391")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=3d25488afbc2eeaa92b12f7f8b6d686e7ef342eb")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2018.01.19.r3252.6bc4a2376" "linux-hardened=4.14.14.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2018.02.05.r3278.3d25488af" "linux-hardened=4.14.17.a-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.14-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.14-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.17-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.17-1-hardened/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.14-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.17-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index c0031253fc95..9429d0aefb1a 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.14-1-hardened
+ depmod -a 4.14.17-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'