summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-21 18:56:17 -0800
committerJesus Alvarez2017-12-21 18:56:17 -0800
commitc230ed76e359b55ee259cd2a096bc3db70d0cc63 (patch)
tree9a7e14101d580822dda09028e5dbfca6b5b83c53
parent80f7f86b482c9c34f675422958601fc63fbaeaa8 (diff)
downloadaur-c230ed76e359b55ee259cd2a096bc3db70d0cc63.tar.gz
Semi-automated update for 4.14.8.b.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--zfs.install2
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffdb7fe04af1..4700e9be6318 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Mon Dec 18 22:23:05 UTC 2017
+# Fri Dec 22 01:03:35 UTC 2017
pkgbase = zfs-linux-hardened-git
- pkgver = 2017.12.18.r3214.bbffb59ef.4.14.7.a.1
+ pkgver = 2017.12.21.r3220.a8b2e3068.4.14.8.b.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.14.7.a-1
+ makedepends = linux-hardened-headers=4.14.8.b-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
- depends = zfs-utils-common-git=2017.12.18.r3214.bbffb59ef
- depends = linux-hardened=4.14.7.a-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=bbffb59efc49baba1d131d497202e8cda0068c3d
+ depends = zfs-utils-common-git=2017.12.21.r3220.a8b2e3068
+ depends = linux-hardened=4.14.8.b-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=a8b2e30685c9214ccfd0181977540e080340df4e
sha256sums = SKIP
pkgname = zfs-linux-hardened-git
diff --git a/PKGBUILD b/PKGBUILD
index 46419796ace4..6fd5e25495a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,24 +18,24 @@
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=2017.12.18.r3214.bbffb59ef.4.14.7.a.1
+pkgver=2017.12.21.r3220.a8b2e3068.4.14.8.b.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.7.a-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.14.8.b-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=bbffb59efc49baba1d131d497202e8cda0068c3d")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=a8b2e30685c9214ccfd0181977540e080340df4e")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2017.12.18.r3214.bbffb59ef" "linux-hardened=4.14.7.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2017.12.21.r3220.a8b2e3068" "linux-hardened=4.14.8.b-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.4 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.7-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.7-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.8-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.8-1-hardened/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.7-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.8-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 6f61d26b3b24..15f448942872 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.7-1-hardened
+ depmod -a 4.14.8-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'