summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchzfs Buildbot2018-07-22 18:43:52 +0000
committerArchzfs Buildbot2018-07-22 18:43:52 +0000
commitd5bdc106aac1ce059628074fcc308b7826026524 (patch)
tree214937cc5e4376c80fc2bf678b304666cc13f63a
parentde0d92d92e9cb1fe342d19755955607891ec8778 (diff)
downloadaur-d5bdc106aac1ce059628074fcc308b7826026524.tar.gz
Semi-automated update for kernel 4.17.8.a-1 + latest git commit
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--zfs.install2
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a4293f10532..4cb89c208724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux-hardened-git
- pkgver = 2018.06.27.r4617.g3be1eb29d.4.17.3.a.1
+ pkgver = 2018.07.12.r4637.g2e5dc449c.4.17.8.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.17.3.a-1
+ makedepends = linux-hardened-headers=4.17.8.a-1
makedepends = git
depends = kmod
- depends = zfs-utils-common-git=2018.06.27.r4617.g3be1eb29d
- depends = linux-hardened=4.17.3.a-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=3be1eb29dab4e96249de7832d9b3dae5740c33c8
+ depends = zfs-utils-common-git=2018.07.12.r4637.g2e5dc449c
+ depends = linux-hardened=4.17.8.a-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=2e5dc449c1a65e0b0bf730fd69c9b5804bd57ee8
sha256sums = SKIP
pkgname = zfs-linux-hardened-git
diff --git a/PKGBUILD b/PKGBUILD
index eccd8164bd14..2645b67f9bbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+# Maintainer: Jan Houben <jan@nexttrex.de>
+# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
#
# This PKGBUILD was generated by the archzfs build scripts located at
#
@@ -14,19 +15,18 @@
# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
# archzfs github page.
#
-#
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=2018.06.27.r4617.g3be1eb29d.4.17.3.a.1
+pkgver=2018.07.12.r4637.g2e5dc449c.4.17.8.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.17.3.a-1" "git")
+makedepends=("linux-hardened-headers=4.17.8.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=3be1eb29dab4e96249de7832d9b3dae5740c33c8")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=2e5dc449c1a65e0b0bf730fd69c9b5804bd57ee8")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "zfs-utils-common-git=2018.06.27.r4617.g3be1eb29d" "linux-hardened=4.17.3.a-1")
+depends=("kmod" "zfs-utils-common-git=2018.07.12.r4637.g2e5dc449c" "linux-hardened=4.17.8.a-1")
build() {
cd "${srcdir}/zfs"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.17.3-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.17.3-1-hardened/build
+ --with-linux=/usr/lib/modules/4.17.8-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.17.8-1-hardened/build
make
}
@@ -61,5 +61,5 @@ package_zfs-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.17.3-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.17.8-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 7a43868bbf86..9431ce814258 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.17.3-1-hardened
+ depmod -a 4.17.8-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'