summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-01-18 16:27:28 -0800
committerJesus Alvarez2018-01-18 16:27:28 -0800
commitfd1c60a3e9aef0396936f1f71ed799b32011a329 (patch)
tree5990ff29912c541b54f677821e33b29db1cea494
parent9fcbed8d24d435cecfc911101af093c8ade3a812 (diff)
downloadaur-fd1c60a3e9aef0396936f1f71ed799b32011a329.tar.gz
Semi-automated update for 4.14.14.a.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install2
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b684c999a6a..38fb6d87e378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Jan 14 20:17:51 UTC 2018
+# Thu Jan 18 23:59:57 UTC 2018
pkgbase = zfs-linux-hardened-git
- pkgver = 2018.01.12.r3242.c10cdcb55.4.14.13.a.1
+ pkgver = 2018.01.18.r3248.7da8f8d81.4.14.14.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.14.13.a-1
+ makedepends = linux-hardened-headers=4.14.14.a-1
makedepends = git
makedepends = spl-linux-hardened-git-headers
depends = kmod
depends = spl-linux-hardened-git
- depends = zfs-utils-common-git=2018.01.12.r3242.c10cdcb55
- depends = linux-hardened=4.14.13.a-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=c10cdcb55f81ea773486161b31bc91bb7b58b4c8
+ depends = zfs-utils-common-git=2018.01.18.r3248.7da8f8d81
+ depends = linux-hardened=4.14.14.a-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=7da8f8d81bf1fadc2d9dff10f0435fe601e919fa
sha256sums = SKIP
pkgname = zfs-linux-hardened-git
diff --git a/PKGBUILD b/PKGBUILD
index 3b6d2c6c0f95..cc1e2fde630a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,15 @@
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=2018.01.12.r3242.c10cdcb55.4.14.13.a.1
+pkgver=2018.01.18.r3248.7da8f8d81.4.14.14.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.13.a-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.14.14.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=c10cdcb55f81ea773486161b31bc91bb7b58b4c8")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=7da8f8d81bf1fadc2d9dff10f0435fe601e919fa")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2018.01.12.r3242.c10cdcb55" "linux-hardened=4.14.13.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2018.01.18.r3248.7da8f8d81" "linux-hardened=4.14.14.a-1")
build() {
cd "${srcdir}/zfs"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.13-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.13-1-hardened/build
+ --with-linux=/usr/lib/modules/4.14.14-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.14-1-hardened/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.13-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.14-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index bd8bbbc91cf5..c0031253fc95 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.13-1-hardened
+ depmod -a 4.14.14-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'