summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Houben2018-11-26 13:35:35 -0500
committerJan Houben2018-11-26 13:35:35 -0500
commit486a8789588f55c028c4bbd48871cd30c5f37cbb (patch)
tree70e80c767ca67e50de44d4e99a985039dd12f515
downloadaur-486a8789588f55c028c4bbd48871cd30c5f37cbb.tar.gz
Initial commit
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD68
-rw-r--r--zfs.install8
4 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d3ff5ef39ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = zfs-linux-lts-rc
+ pkgver = 0.8.0_rc2_4.14.82.1
+ pkgrel = 2
+ url = http://zfsonlinux.org/
+ arch = x86_64
+ license = CDDL
+ makedepends = linux-lts-headers=4.14.82-1
+ makedepends = spl-linux-lts-headers
+ depends = kmod
+ depends = zfs-utils-rc=0.8.0_rc2
+ depends = linux-lts=4.14.82-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.8.0-rc2/zfs-0.8.0-rc2.tar.gz
+ sha256sums = 66fa2aa270586dc3c0f64d08b83f126f288163d6fb622e8d85e3e86a118a2082
+
+pkgname = zfs-linux-lts-rc
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ install = zfs.install
+ groups = archzfs-linux-lts-rc
+ provides = zfs
+ provides = spl
+ conflicts = zfs-dkms
+ conflicts = zfs-dkms-git
+ conflicts = zfs-dkms-rc
+ conflicts = zfs-linux-lts
+ conflicts = zfs-linux-lts-git
+ conflicts = spl-linux-lts
+ conflicts = spl-dkms
+ conflicts = spl-dkms-git
+
+pkgname = zfs-linux-lts-rc-headers
+ pkgdesc = Kernel headers for the Zettabyte File System.
+ provides = zfs-headers
+ provides = spl-headers
+ conflicts = zfs-headers
+ conflicts = zfs-dkms
+ conflicts = zfs-dkms-git
+ conflicts = zfs-dkms-rc
+ conflicts = spl-dkms
+ conflicts = spl-dkms-git
+ conflicts = spl-headers
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..206ea9392201
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+*.sig
+*.log \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4af1f1e776fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Jan Houben <jan@nexttrex.de>
+# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux-lts packages will only work with the default linux-lts package! To have a single PKGBUILD target
+# many kernels would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+pkgbase="zfs-linux-lts-rc"
+pkgname=("zfs-linux-lts-rc" "zfs-linux-lts-rc-headers")
+_zfsver="0.8.0_rc2"
+_kernelver="4.14.82-1"
+_extramodules="4.14.82-1-lts"
+
+pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
+pkgrel=2
+makedepends=("linux-lts-headers=${_kernelver}" "spl-linux-lts-headers")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_zfsver/_/-}/zfs-${_zfsver/_/-}.tar.gz")
+sha256sums=("66fa2aa270586dc3c0f64d08b83f126f288163d6fb622e8d85e3e86a118a2082")
+license=("CDDL")
+depends=("kmod" "zfs-utils-rc=${_zfsver}" "linux-lts=${_kernelver}")
+
+build() {
+ cd "${srcdir}/zfs-${_zfsver/_rc*/}"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
+ --datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
+ --libexecdir=/usr/lib/zfs-${zfsver} --with-config=kernel \
+ --with-linux=/usr/lib/modules/${_extramodules}/build \
+ --with-linux-obj=/usr/lib/modules/${_extramodules}/build
+ make
+}
+
+package_zfs-linux-lts-rc() {
+ pkgdesc="Kernel modules for the Zettabyte File System."
+ install=zfs.install
+ provides=("zfs" "spl")
+ groups=("archzfs-linux-lts-rc")
+ conflicts=("zfs-dkms" "zfs-dkms-git" "zfs-dkms-rc" 'zfs-linux-lts' 'zfs-linux-lts-git' 'spl-linux-lts' "spl-dkms" "spl-dkms-git")
+ cd "${srcdir}/zfs-${_zfsver/_rc*/}"
+ make DESTDIR="${pkgdir}" install
+ cp -r "${pkgdir}"/{lib,usr}
+ rm -r "${pkgdir}"/lib
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_zfs-linux-lts-rc-headers() {
+ pkgdesc="Kernel headers for the Zettabyte File System."
+ provides=("zfs-headers" "spl-headers")
+ conflicts=("zfs-headers" "zfs-dkms" "zfs-dkms-git" "zfs-dkms-rc" "spl-dkms" "spl-dkms-git" "spl-headers")
+ cd "${srcdir}/zfs-${_zfsver/_rc*/}"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/${_extramodules}/Module.symvers
+}
diff --git a/zfs.install b/zfs.install
new file mode 100644
index 000000000000..c2a2d7807e6d
--- /dev/null
+++ b/zfs.install
@@ -0,0 +1,8 @@
+post_remove() {
+ MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
+ if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
+ echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
+ echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
+ echo '>>> "hooks" list and then regenerate the initial ramdisk.'
+ fi
+}