summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-07-30 17:41:06 -0700
committerJesus Alvarez2017-07-30 17:41:06 -0700
commit360ecb8f4d3c5e43019f0c37acb45be8fb388936 (patch)
tree3b4ea6acb46ec82e6f0570172b6d0c79f9cd22bb
parent2df4db06dc9b18978fd6fc9115baae2c009e9790 (diff)
downloadaur-360ecb8f4d3c5e43019f0c37acb45be8fb388936.tar.gz
Semi-automated update for 4.9.40_1-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
-rw-r--r--zfs.install15
3 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e0ef72960d2..f35669caf110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Jul 28 09:02:52 UTC 2017
+# Sun Jul 30 22:30:38 UTC 2017
pkgbase = zfs-linux-lts
- pkgver = 0.7.0_4.9.37_1
+ pkgver = 0.7.0_4.9.40_1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-lts-headers=4.9.37
+ makedepends = linux-lts-headers=4.9.40
makedepends = libelf
makedepends = spl-linux-lts-headers
depends = kmod
depends = spl-linux-lts
- depends = zfs-utils-common
- depends = linux-lts=4.9.37
+ depends = zfs-utils-common>=0.7.0
+ depends = linux-lts=4.9.40
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz
sha256sums = 6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2
@@ -25,9 +25,10 @@ pkgname = zfs-linux-lts
pkgname = zfs-linux-lts-headers
pkgdesc = Kernel headers for the Zettabyte File System.
+ conflicts = zfs-archiso-linux-headers
+ conflicts = zfs-linux-hardened-headers
+ conflicts = zfs-linux-hardened-git-headers
conflicts = zfs-linux-lts-git-headers
conflicts = zfs-linux-headers
conflicts = zfs-linux-git-headers
- conflicts = zfs-linux-hardened-headers
- conflicts = zfs-linux-hardened-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 7da6b20f10b1..9f891581c78b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
#
pkgbase="zfs-linux-lts"
pkgname=("zfs-linux-lts" "zfs-linux-lts-headers")
-pkgver=0.7.0_4.9.37_1
+pkgver=0.7.0_4.9.40_1
pkgrel=1
-makedepends=("linux-lts-headers=4.9.37" "libelf" "spl-linux-lts-headers")
+makedepends=("linux-lts-headers=4.9.40" "libelf" "spl-linux-lts-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz")
sha256sums=("6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2")
license=("CDDL")
-depends=("kmod" "spl-linux-lts" "zfs-utils-common" "linux-lts=4.9.37")
+depends=("kmod" "spl-linux-lts" "zfs-utils-common>=0.7.0" "linux-lts=4.9.40")
build() {
cd "${srcdir}/zfs-0.7.0"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.0 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.9.37-1-lts/build \
- --with-linux-obj=/usr/lib/modules/4.9.37-1-lts/build
+ --with-linux=/usr/lib/modules/4.9.40-1-lts/build \
+ --with-linux-obj=/usr/lib/modules/4.9.40-1-lts/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux-lts() {
package_zfs-linux-lts-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers')
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
cd "${srcdir}/zfs-0.7.0"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.9.37-1-lts/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.9.40-1-lts/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index db6d6f4d6431..6d7d7c2ac42f 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,16 +12,11 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.9.37-1-lts
+ depmod -a 4.9.40-1-lts
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
- if [[ ${MK_CONF} == '0' ]]; then
- if [[ $1 == 'remove' ]]; then
- echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
- echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
- echo '>>> "hooks" list and then regenerate the initial ramdisk.'
- else
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux-lts
- fi
+ if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
+ echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
+ echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
+ echo '>>> "hooks" list and then regenerate the initial ramdisk.'
fi
}