summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Haller2022-06-21 18:52:21 -0500
committerAngelo Haller2022-06-21 18:52:21 -0500
commitcbf8d62ef83ea125c98b47ac9c7cf37c9cd3d981 (patch)
treeae3c3ad0918fde9a4928ba6e925b8d8b4b75a00e
parent8a803ceff5a7d21b79230752a9db9a9916961072 (diff)
downloadaur-cbf8d62ef83ea125c98b47ac9c7cf37c9cd3d981.tar.gz
Update to RT kernel 5.17.1.17.realtime2-3 and zfs 2.1.4.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 362b8bab942d..53cc0a314d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux-rt
- pkgver = 2.1.2_5.15.5.22.realtime1.1
+ pkgver = 2.1.4_5.17.1.17.realtime2.3
pkgrel = 1
url = https://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-rt-headers=5.15.5.22.realtime1-1
+ makedepends = linux-rt-headers=5.17.1.17.realtime2-3
depends = kmod
- depends = zfs-utils=2.1.2
- depends = linux-rt=5.15.5.22.realtime1-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-2.1.2/zfs-2.1.2.tar.gz
- sha256sums = 258cf1d17a1f668a3b99b61eaf14be06c614df42503db0319bef1b9fc4c8b9e7
+ depends = zfs-utils=2.1.4
+ depends = linux-rt=5.17.1.17.realtime2-3
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-2.1.4/zfs-2.1.4.tar.gz
+ sha256sums = 3b52c0d493f806f638dca87dde809f53861cd318c1ebb0e60daeaa061cf1acf6
pkgname = zfs-linux-rt
pkgdesc = Kernel modules for the Zettabyte File System.
diff --git a/PKGBUILD b/PKGBUILD
index 6019e95cd3f3..ef38af519827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,15 @@
# Contributor: Jan Houben <jan@nexttrex.de>
# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
#
-# This PKGBUILD was generated by the archzfs build scripts located at
-#
-# http://github.com/archzfs/archzfs
-#
-# ! WARNING !
-#
-# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
-# case, the archzfs-linux-lts packages will only work with the default linux-lts package! To have a single PKGBUILD target
-# many kernels would make for a cluttered PKGBUILD!
-#
-# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
-# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
-# archzfs github page.
+# WARNING: This package does not build in its current form due to licensing
+# incompatibilities. Some of the linux-rt patches change some of the exported
+# kernel symbols to GPL-only which conflicts with the zfs CDDL license.
#
pkgbase="zfs-linux-rt"
pkgname=("zfs-linux-rt" "zfs-linux-rt-headers")
-_zfsver="2.1.2"
-_kernelver="5.15.5.22.realtime1-1"
-_extramodules="5.15.5.22.realtime1-1-rt"
+_zfsver="2.1.4"
+_kernelver="5.17.1.17.realtime2-3"
+_extramodules="5.17.1.17.realtime2-3-rt"
pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
pkgrel=1
@@ -28,7 +18,7 @@ makedepends=("linux-rt-headers=${_kernelver}")
arch=("x86_64")
url="https://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_zfsver}/zfs-${_zfsver}.tar.gz")
-sha256sums=('258cf1d17a1f668a3b99b61eaf14be06c614df42503db0319bef1b9fc4c8b9e7')
+sha256sums=('3b52c0d493f806f638dca87dde809f53861cd318c1ebb0e60daeaa061cf1acf6')
license=("CDDL")
depends=("kmod" "zfs-utils=${_zfsver}" "linux-rt=${_kernelver}")
@@ -50,7 +40,7 @@ package_zfs-linux-rt() {
groups=("archzfs-linux-rt")
conflicts=("zfs-dkms" "zfs-dkms-git" "zfs-dkms-rc" "spl-dkms" "spl-dkms-git")
cd "${srcdir}/zfs-${_zfsver}"
- make DESTDIR="${pkgdir}" INSTALL_MOD_PATH=/usr install
+ make DESTDIR="${pkgdir}" INSTALL_MOD_PATH=${pkgdir}/usr INSTALL_MOD_STRIP=1 install
# Remove src dir
rm -r "${pkgdir}"/usr/src
}