summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchzfs Buildbot2018-12-31 03:20:15 +0000
committerArchzfs Buildbot2018-12-31 03:20:15 +0000
commit8d6cd93ddb5dfa2233bcfef5460d5ec04c6a13ed (patch)
tree9c287831a144c0c01d53ee3b75cd9daf797a5f87
parent8ce1913360752bdf44e9567d6522c8be97a3b242 (diff)
downloadaur-8d6cd93ddb5dfa2233bcfef5460d5ec04c6a13ed.tar.gz
Semi-automated update for kernel 4.19.9.arch1-1 + latest git commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch19
3 files changed, 29 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c99151e43c5..70ea08350dec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = zfs-linux-vfio-git
- pkgver = 2018.12.18.r4869.g00f198de6_4.19.9.arch1.1
+ pkgver = 2018.12.26.r4871.g06f3fc2a4_4.19.9.arch1.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
@@ -7,9 +7,9 @@ pkgbase = zfs-linux-vfio-git
makedepends = linux-vfio-headers=4.19.9.arch1-1
makedepends = git
depends = kmod
- depends = zfs-utils-git=2018.12.18.r4869.g00f198de6
+ depends = zfs-utils-git=2018.12.26.r4871.g06f3fc2a4
depends = linux-vfio=4.19.9.arch1-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=00f198de6b6ac663926bff2666d956a61cea85db
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=06f3fc2a4b097545259935d54634c5c6f49ed20f
sha256sums = SKIP
pkgname = zfs-linux-vfio-git
diff --git a/PKGBUILD b/PKGBUILD
index 090e0786ecda..e5588bf844a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,18 +17,20 @@
#
pkgbase="zfs-linux-vfio-git"
pkgname=("zfs-linux-vfio-git" "zfs-linux-vfio-git-headers")
-_commit='00f198de6b6ac663926bff2666d956a61cea85db'
-_zfsver="2018.12.18.r4869.g00f198de6"
+_commit='06f3fc2a4b097545259935d54634c5c6f49ed20f'
+_zfsver="2018.12.26.r4871.g06f3fc2a4"
_kernelver="4.19.9.arch1-1"
-_extramodules="${_kernelver/.arch/-arch}-vfio"
+_extramodules="4.19.9-arch1-1-vfio"
pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
pkgrel=1
makedepends=("linux-vfio-headers=${_kernelver}" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}")
-sha256sums=("SKIP")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}"
+ "upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch")
+sha256sums=("SKIP"
+ "6f27c3dae57c424e06aec31df6c1e1a821e547aa4e933f2f9b894b5e6762b52d")
license=("CDDL")
depends=("kmod" "zfs-utils-git=${_zfsver}" "linux-vfio=${_kernelver}")
diff --git a/upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch b/upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch
new file mode 100644
index 000000000000..e36752293987
--- /dev/null
+++ b/upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch
@@ -0,0 +1,19 @@
+diff --git a/include/zpios-ctl.h b/include/zpios-ctl.h
+index f17f1153260..068c9eaf173 100644
+--- a/include/zpios-ctl.h
++++ b/include/zpios-ctl.h
+@@ -181,9 +181,12 @@ zpios_timespec_t
+ zpios_timespec_now(void)
+ {
+ zpios_timespec_t zts_now;
+- struct timespec ts_now;
++ #if defined(HAVE_INODE_TIMESPEC64_TIMES)
++ inode_timespec_t ts_now = current_kernel_time64();
++ #else
++ inode_timespec_t ts_now = current_kernel_time();
++ #endif
+
+- ts_now = current_kernel_time();
+ zts_now.ts_sec = ts_now.tv_sec;
+ zts_now.ts_nsec = ts_now.tv_nsec;
+