summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2020-10-09 13:04:08 -0400
committerEli Schwartz2020-10-09 16:01:48 -0400
commit4d76893b86f73b4c1ff434c5c765d50b4b95087f (patch)
tree11410d646be422dcc56bcbfe652d889e8fa26d7c
parentbc6da8e5b9cced0ba218c367759012f7cc460e09 (diff)
downloadaur-4d76893b86f73b4c1ff434c5c765d50b4b95087f.tar.gz
zfs initcpio hook: fix incorrect shell redirection
In order to fulfill the intended purpose, one must redirect to /dev/null before redirecting stderr. Otherwise stderr just goes to the console on stdout...
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--zfs.initcpio.hook2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef3e53cbd036..18275056ce66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,10 +16,10 @@ pkgbase = zfs-utils
sha256sums = 2b988f5777976f09d08083f6bebf6e67219c4c4c183c1f33033fb7e5e5eacafb
sha256sums = SKIP
sha256sums = da1cdc045d144d2109ec7b5d97c53a69823759d8ecff410e47c3a66b69e6518d
- sha256sums = f95ad1a5421ccbb8b01f448373f46cfd1f718361a82c2687a597325cf9827e3e
+ sha256sums = 9c20256093997f7cfa9e7eb5d85d4a712d528a6ff19ef35b83ad03fb1ceae3bc
b2sums = 776bcd6dfab8825c07d315085e288b29bf543d6957325d5d566b7b78c04505dde9bd25eb6684cb4a1b6a657de8a4e1290d04d2b9079d26d6b834a70f1ec3b569
b2sums = SKIP
b2sums = 570e995bba07ea0fb424dff191180b8017b6469501964dc0b70fd51e338a4dad260f87cc313489866cbfd1583e4aac2522cf7309c067cc5314eb83c37fe14ff3
- b2sums = 491a7f20b0c6b4ce4fcedab617b2d7a4f2a01f1bc8f1ae57efde2fb22c2ab09a1107a8f4877b95c27576fe4216d01f181936787f51ce532bb13c5806badf7519
+ b2sums = e14366cbf680e3337d3d478fe759a09be224c963cc5207bee991805312afc49a49e6691f11e5b8bbe8dde60e8d855bd96e7f4f48f24a4c6d4a8c1bab7fc2bba0
pkgname = zfs-utils
diff --git a/PKGBUILD b/PKGBUILD
index 784e201b4cb1..d31d17c0e3ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,11 @@ source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${pkgver}/zfs-$
sha256sums=('2b988f5777976f09d08083f6bebf6e67219c4c4c183c1f33033fb7e5e5eacafb'
'SKIP'
'da1cdc045d144d2109ec7b5d97c53a69823759d8ecff410e47c3a66b69e6518d'
- 'f95ad1a5421ccbb8b01f448373f46cfd1f718361a82c2687a597325cf9827e3e')
+ '9c20256093997f7cfa9e7eb5d85d4a712d528a6ff19ef35b83ad03fb1ceae3bc')
b2sums=('776bcd6dfab8825c07d315085e288b29bf543d6957325d5d566b7b78c04505dde9bd25eb6684cb4a1b6a657de8a4e1290d04d2b9079d26d6b834a70f1ec3b569'
'SKIP'
'570e995bba07ea0fb424dff191180b8017b6469501964dc0b70fd51e338a4dad260f87cc313489866cbfd1583e4aac2522cf7309c067cc5314eb83c37fe14ff3'
- '491a7f20b0c6b4ce4fcedab617b2d7a4f2a01f1bc8f1ae57efde2fb22c2ab09a1107a8f4877b95c27576fe4216d01f181936787f51ce532bb13c5806badf7519')
+ 'e14366cbf680e3337d3d478fe759a09be224c963cc5207bee991805312afc49a49e6691f11e5b8bbe8dde60e8d855bd96e7f4f48f24a4c6d4a8c1bab7fc2bba0')
validpgpkeys=('4F3BA9AB6D1F8D683DC2DFB56AD860EED4598027' # Tony Hutter (GPG key for signing ZFS releases) <hutter2@llnl.gov>
'C33DF142657ED1F7C328A2960AB9E991C6AF658B') # Brian Behlendorf <behlendorf1@llnl.gov>
diff --git a/zfs.initcpio.hook b/zfs.initcpio.hook
index 7288ab8018b3..e0f4cfb386ca 100644
--- a/zfs.initcpio.hook
+++ b/zfs.initcpio.hook
@@ -39,7 +39,7 @@ zfs_mount_handler () {
local pool="${ZFS_DATASET%%/*}"
local rwopt_exp="${rwopt:-ro}"
- if ! zpool list -H "${pool}" 2>&1 > /dev/null ; then
+ if ! zpool list -H "${pool}" >/dev/null 2>&1; then
if [ ! "${rwopt_exp}" = "rw" ]; then
msg "ZFS: Importing pool ${pool} readonly."
ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -o readonly=on"