summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2020-07-19 14:13:16 -0400
committerEli Schwartz2020-07-19 14:13:16 -0400
commitbc6da8e5b9cced0ba218c367759012f7cc460e09 (patch)
tree0df763eed597082fe3e896eb80d40fee1397d4d1
parentd149d59f065c11b5a25a47e1a93cf6baa5934d6d (diff)
downloadaur-bc6da8e5b9cced0ba218c367759012f7cc460e09.tar.gz
zfs-utils*/: add explicit --enable-systemd
It should already be installed, but makechrootpkg might non-conformantly not have it installed leading to broken system probing. Short-circuit the check entirely. Also clean up some autotools path args that were already the default.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 1 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f51a185fb5a2..ef3e53cbd036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,4 +23,3 @@ pkgbase = zfs-utils
b2sums = 491a7f20b0c6b4ce4fcedab617b2d7a4f2a01f1bc8f1ae57efde2fb22c2ab09a1107a8f4877b95c27576fe4216d01f181936787f51ce532bb13c5806badf7519
pkgname = zfs-utils
-
diff --git a/PKGBUILD b/PKGBUILD
index 140b4125d5c5..784e201b4cb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,13 +39,11 @@ build() {
--sysconfdir=/etc \
--sbindir=/usr/bin \
--with-mounthelperdir=/usr/bin \
- --libdir=/usr/lib \
- --datadir=/usr/share \
- --includedir=/usr/include \
--with-udevdir=/usr/lib/udev \
--libexecdir=/usr/lib/zfs \
--with-python="$PWD/python3-fake" \
--enable-pyzfs=no \
+ --enable-systemd \
--with-config=user
make
}