summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchzfs Buildbot2018-09-08 10:25:48 +0000
committerArchzfs Buildbot2018-09-08 10:25:48 +0000
commit8d15b4807c1195adc015665d1130b81e15ca78ba (patch)
treebe390aeb9c53ace31db1ea37641bf3160496aeee
parent32165c0698eeb18768a9f3043a752861310c8be2 (diff)
downloadaur-8d15b4807c1195adc015665d1130b81e15ca78ba.tar.gz
Semi-automated update for latest git commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--zfs-utils.initcpio.hook8
-rw-r--r--zfs-utils.initcpio.install2
4 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc7db78f7796..ff7443642951 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zfs-utils-common-git
pkgdesc = Kernel module support files for the Zettabyte File System.
- pkgver = 2018.08.23.r4692.g55972a672
+ pkgver = 2018.09.07.r4720.gb8a90418f
pkgrel = 1
url = http://zfsonlinux.org/
install = zfs-utils.install
@@ -16,7 +16,7 @@ pkgbase = zfs-utils-common-git
replaces = spl-utils-common-git
backup = etc/zfs/zed.d/zed.rc
backup = etc/default/zfs
- source = git+https://github.com/zfsonlinux/zfs.git#commit=55972a6724ca49d98d67a47fe0f0b28ad21260d5
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=b8a90418f3a9c23b89c5d2c729a4dd0fea644508
source = zfs-utils.bash-completion-r1
source = zfs-utils.initcpio.install
source = zfs-utils.initcpio.hook
diff --git a/PKGBUILD b/PKGBUILD
index 444caf326f2d..9a6c3c22b02f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,24 @@
# http://github.com/archzfs/archzfs
#
pkgname="zfs-utils-common-git"
+_commit='b8a90418f3a9c23b89c5d2c729a4dd0fea644508'
-pkgver=2018.08.23.r4692.g55972a672
+pkgver=2018.09.07.r4720.gb8a90418f
pkgrel=1
pkgdesc="Kernel module support files for the Zettabyte File System."
depends=("python2")
makedepends=("git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=55972a6724ca49d98d67a47fe0f0b28ad21260d5"
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}"
"zfs-utils.bash-completion-r1"
"zfs-utils.initcpio.install"
"zfs-utils.initcpio.hook"
"zfs-utils.initcpio.zfsencryptssh.install")
sha256sums=("SKIP"
"b60214f70ffffb62ffe489cbfabd2e069d14ed2a391fac0e36f914238394b540"
- "335e309ebf5b74fd8956f5e8805939c37d4008b0bcc3b00be6e7ef1d5b7c1669"
- "60ca3ce382c404c1c97873d6a352d0e99b28e948fde4e3f67d92e05f6eb216f0"
+ "6e5e905a322d0426acdcbc05c5651ec78ee7b874b96d3c429c80f68b061170c5"
+ "ae1cda85de0ad8b9ec8158a66d02485f3d09c37fb13b1567367220a720bcc9a5"
"29080a84e5d7e36e63c4412b98646043724621245b36e5288f5fed6914da5b68")
license=("CDDL")
groups=("archzfs-linux-git")
@@ -37,7 +38,7 @@ build() {
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --with-mounthelperdir=/usr/bin \
--libdir=/usr/lib --datadir=/usr/share --includedir=/usr/include \
- --with-udevdir=/lib/udev --libexecdir=/usr/lib/zfs-0.7.9 \
+ --with-udevdir=/lib/udev --libexecdir=/usr/lib/zfs-${pkgver} \
--with-config=user --enable-systemd
make
}
diff --git a/zfs-utils.initcpio.hook b/zfs-utils.initcpio.hook
index bf9c6dc252f5..b47cc2849c9e 100644
--- a/zfs-utils.initcpio.hook
+++ b/zfs-utils.initcpio.hook
@@ -60,7 +60,8 @@ zfs_mount_handler () {
# Lets import everything and try again
zpool import ${ZPOOL_IMPORT_FLAGS} -N -a ${ZPOOL_FORCE}
if ! zfs_get_bootfs ; then
- die "ZFS: Cannot find bootfs."
+ err "ZFS: Cannot find bootfs."
+ exit 1
fi
fi
fi
@@ -77,7 +78,8 @@ zfs_mount_handler () {
fi
if ! zpool import ${ZPOOL_IMPORT_FLAGS} -N "${pool}" ${ZPOOL_FORCE} ; then
- die "ZFS: Unable to import pool ${pool}."
+ err "ZFS: Unable to import pool ${pool}."
+ exit 1
fi
fi
@@ -117,7 +119,7 @@ set_flags() {
# Add import directory to import command flags
[ ! "${zfs_import_dir}" = "" ] && ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -d ${zfs_import_dir}"
- [ "${zfs_import_dir}" = "" ] && [ -f /etc/zfs/zpool.cache ] && ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -c /etc/zfs/zpool.cache"
+ [ "${zfs_import_dir}" = "" ] && [ -f /etc/zfs/zpool.cache.org ] && ZPOOL_IMPORT_FLAGS="${ZPOOL_IMPORT_FLAGS} -c /etc/zfs/zpool.cache.org"
}
run_hook() {
diff --git a/zfs-utils.initcpio.install b/zfs-utils.initcpio.install
index c3d5a9860aae..8b646a101a04 100644
--- a/zfs-utils.initcpio.install
+++ b/zfs-utils.initcpio.install
@@ -41,7 +41,7 @@ build() {
# allow mount(8) to "autodetect" ZFS
echo 'zfs' >>"${BUILDROOT}/etc/filesystems"
- [[ -f /etc/zfs/zpool.cache ]] && add_file "/etc/zfs/zpool.cache"
+ [[ -f /etc/zfs/zpool.cache ]] && cp "/etc/zfs/zpool.cache" "${BUILDROOT}/etc/zfs/zpool.cache.org"
[[ -f /etc/modprobe.d/zfs.conf ]] && add_file "/etc/modprobe.d/zfs.conf"
}