summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2020-07-19 14:13:16 -0400
committerEli Schwartz2020-07-19 14:13:16 -0400
commit5880411fd8ad0cf61d3075b3838cb0214f5cb70d (patch)
tree8f32c043d47684c8baa615ed91d29ddbb21a55f1
parentafd1d3e734eda168996aca8752f51b1416023e45 (diff)
downloadaur-5880411fd8ad0cf61d3075b3838cb0214f5cb70d.tar.gz
zfs-utils*/: add explicit --enable-systemd
It should already be installed, but makechrootpkg might non-conformantly not have it installed leading to broken system probing. Short-circuit the check entirely. Also clean up some autotools path args that were already the default.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 1 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9605c56ecfc4..92ebe29f5787 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,4 +22,3 @@ pkgbase = zfs-utils-git
b2sums = 491a7f20b0c6b4ce4fcedab617b2d7a4f2a01f1bc8f1ae57efde2fb22c2ab09a1107a8f4877b95c27576fe4216d01f181936787f51ce532bb13c5806badf7519
pkgname = zfs-utils-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3ca35d10d4e6..1066df4daa18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,13 +48,11 @@ build() {
--sysconfdir=/etc \
--sbindir=/usr/bin \
--with-mounthelperdir=/usr/bin \
- --libdir=/usr/lib \
- --datadir=/usr/share \
- --includedir=/usr/include \
--with-udevdir=/usr/lib/udev \
--libexecdir=/usr/lib/zfs \
--with-python="$PWD/python3-fake" \
--enable-pyzfs=no \
+ --enable-systemd \
--with-config=user
make
}